Dimension issue

dimensions

#1

Hello

I have scaled my viewport in Layout to 1"=10’ but dimensions aren’t reflecting the scale change.

Here is screen shot and file.

DIM

16MCsite.layout (1.3 MB)

Would anyone have any advice on solving this problem


#2

You’ve got lines drawn in LayOut laid over the SketchUp viewport and your dimensions are attaching to them so you are getting paper space dimensions, not model space dimensions. The dimensions will be correct when you dimension the model instead.

I’m not sure why you have traced over the model viewport. I suppose there’s a reason. You should be separating entities in your LO project by using layers. Put the model viewports on one layer (or more if you are stacking them) and things you draw in LayOut on another layer or maybe layers depending on what you are drawing. Dimensions go on another layer higher in the Layers list than all the drawing stuff. Doing that will allow you to have those lines you draw in LayOut over your viewport. When you need to add dimensions and dimension off the model, you can turn off visibility for the layers holding those lines so you access the model only.

Another thing you might consider for the lines drawn in LayOut is to use Scaled Drawing and set the scale to match the viewport. Then you can get correct dimensions off of those lines or between those lines and the SketchUp model.


#3

Understood! Thanks

I traced over to start to vary the line weights in the drawing. I guess scaled drawing would be a better option to render differing line weights?


#4

Scaled drawing would be better for getting correct dimensions. It doesn’t really matter whether you use Scaled Drawing or not for line weights. Line weight in LayOut isn’t any different with scaled or non-scaled drawing.


#5

Is there a correct method for generating line weights in Layout?

For example, in the drawing I sent the dashed setback lines were drawn over the SU model lines.

This doesn’t give a true representation of dashed lines as you can see the SU model lines “beneath”.


#6

I would draw the setback lines in SketchUp, make them a component or group and put that on a “Setbacks” layer. That layer would have a dashed style applied to it. Then I would create a scene showing the house and property lines without the setback lines. Next, turn off the layers for everything but the setback lines and create another scene showing just them. Same camera position for both scenes. Then going to LayOut, create two layers for viewports; one for the house and property lines, the other for the Setback lines. On the bottom House and Property Lines layer position and scale the viewport for the property lines and house outlines. Copy the viewport. (Command-C) Make the Setback Lines layer active, right click somewhere in the window and choose Paste to Current Layer. While the newly pasted viewport is still selected, change the scene to the Setback scene and adjust Line Scale and if needed the scale factor for the dashes at the bottom of the SketchUp Model panel.

This process eliminates the need to trace lines in LayOut and if you have some reason to edit those lines later, you do it in SketchUp and update the reference. If you are dimensioning the setback lines, the dimensions in LayOut should be connected the model so they would update automatically.


#7

Thanks for detailed help, I’ll give it a go.


#8

Sorry one last thing. Not seeing how to apply dashed line style in SU


#9

That’s done in the Layers panel with an assist in the Styles panel. Any components or groups that have a layer with dashes enabled will display the dashes if Dashes are also enabled in the Styles panel.
Screenshot%20-%203_17_2019%20%2C%2012_30_48%20PM

Screenshot%20-%203_17_2019%20%2C%2012_33_24%20PM

This means you can show the edges in a component or group with or without dashes even when the layer has a dash style selected.

When using the dashes, don’t fall into the trap of putting edges on layers other than Layer 0. The rule of keeping Layer 0 active at all times and all edges and faces on Layer 0 still applies.


#10

Ok. I just realized I’m working in SU 2018 not 2019.

Is dashed option new for 2019 or am I missing something in 2018?


#11

Dashes are a new feature in SketchUp 2019 which is what your profile indicates you are using. It would be helpful if your profile was accurate.

You can do something similar in SketchUp 2018 making a separate scene for the setback lines and stacking viewports in LayOut. After you have the setback viewport rendered as Vector, explode it so it becomes LayOut line entities. Then you can select a dash style for those lines in Shape Style. While this works well, if you have some reason to edit the setback lines in SketchUp, you’ll need to redo them in LayOut because exploding the viewport means it’s not a viewport linked to the model anymore.


#12

Thanks. Yes, just realized I was working in 2018…some desktop house cleaning to do. Thanks for the help.