Difficulty printing to scale in SketchUp Pro 2022

I use SketchUp pro 2022 for my woodworking hobby to produce templates. One application is to print full size drawings on Avery full sheet label paper (#8165), adhere the label to my template stock, bandsaw near the line, sand to the line, and use a use a router with a flush trim bit to produce the finished object. The weak link for me is that I am unable to consistently get SketchUp to print full scale. Here is the recommended procedure that I have been following:

  1. set camera to parallel perspective
  2. select one of the standard views (in my case, top)
  3. zoom extents
    When you have multiple entities (maybe scenes), zoom extents really does not do what you want to do. The only way I have been able to get this to work is to copy the entity I am trying to print full scale is to copy it into a new .skp file so that zoom extents produces what I want and then use Print Preview with 1:1 scaling. What am I missing here?

Attached are two files:
print to scale ex.skp (16.1 KB)
pegboard electrical opening.skp (34.6 KB)

Hi Ben,

This is the sort of thing you should do in LayOut. Much easier and more straightforward.

If you must print to scale from SketchUp, resize the model window so it’s more closely fits the shape of the model. Use Zoom Extents to zoom in tightly on the model. In some cases you may need to screw around with the resizing a few times to get it right.

Make the settings as below for printing.


In LayOut, after creating a scene to show the model as desired and saving, Send to LayOut, choose the correct paper size and orientation. Select the scale in the SketchUp Model panel, change rendering to Vector if you wish, either print directly or export to PDF and print that.

Bens Electrical Box Hole.pdf (7.8 KB)

1 Like

One thing to note when printing directly from SketchUp is that when printing small things to full scale, having the “Use model extents” box checked will always split the printout to multiple pages. DaveR has it correctly set up in his screenshot.

OK Dave, you finally brow beat me into trying LayOut; just kidding :slight_smile:.
In the SketchUp arena, you play with the “big boys”. In fact, you are one of the big boys.
In my SketchUp arena, I crawl with a bunch of old codgers. I am trying to pass my SketchUp knowledge to my woodworking club members. Unfortunately, my success rate is only about 10%. Over the last decade, there have been about 50 people (typically 60+) in my classes. Today, there might be 5 people that actually use SketchUp. SketchUp is not for the casual user. I think if I told my students that they have to learn LayOut in addition to SketchUp to print a full size drawing, my success rate would go down even more. I personally would benefit from learning LayOut but for teaching my woodworking club members how to be productive in SketchUp, it looks like I am going to be stuck with copying a front (or top or side) view to a separate .skp file so I can use Zoom Extents.

Thanks for all the help you have given me plus the broader SketchUp community.

1 Like

Hi Ben,

Understood on the teaching front. If you are teaching those folks to do the printing to scale within SketchUp, first teach them about selecting the oobject, right clicking on it, followed by selecting Zoom Selection. Then you don’t have to teach them to copy the component to a new file before printing.

Thanks for the compliments, too. HNY!

FWIW, here’s an example for you.

This is a project for which I made plans. The overall model space looks like this:

There’s a scene to show the parts in 2D for the dimensioned 2-views and 3-views in the plan. I zoomed in on the top of the legs and adjusted the model window to closer to the aspect ratio of the paper.

And the same settings as I used previously get me a 1:1 print on paper.

Thanks as always Dave. Frankly, I had never found “Zoom Selection” and had always been using “Zoom Extents”. In the past under the “Print” menu, I thought I would get an auto fill for “Scale/In the printout” and “Scale/In SketchUp” and I could change the values to 1:1. Now, they come up blank now. Filling in 1:1 seems to work ok.

You’re quite welcome.

I find Zoom Selection useful enough that I set up a keyboard shortcut for it.

That’s probably a print driver issue, I get the same thing but I’m using the Windows XPS Document Writer because I haven’t got a printer mapped to this computer. I’ve found if I do a Print Preview without making any settings, close the preview and go in again, those fields will be filled.