Different appearance SU/LO

styles
style
extensionlines

#1

Does anyone have any idea why I get this happening?

Here are two screenshots of the same drawing, one in SU, the other how it looks in LO. The extension lines are much longer in LO. Also a part of a line showing the corner has disappeared in the LO version. I have not changed the style in LO.

In good WYSIWYG tradition, I expect what I see in SU to be replicated in LO, with LO just providing “windows” into the SU drawing. But maybe there is some global setting I need to change?


#2

To what do you have the extensions set in the style? How big is the viewport in LO?

An interesting thing about the extensions is that their length is determined by pixels. If the viewport is small in LO, it’ll be fewer pixels wide so the extension will appear longer relative to the model than if the viewport is larger. You can see that in this comparison of two copies of the same view but at different sizes. the extensions are actually the same length in both viewports…

The same sort of thing happens in raster image exports from SketchUp.


#3

Dave, thanks for responding once more.

Extensions are set to 2. The viewport takes up maybe one eighth of the drawing size in LO.

I can see the point you are making and I am sure there is a good reason why LO handles extension lines like that, but of course, it doesn’t really replicate old ink drawings, which is surely the intention. The fine construction lines beneath any heavier, later lines, would always extend roughly the same amount regardless of scale, etc.

If there is no way round this, maybe it’s better just to turn off extension lines.


#4

There isn’t any way around this strictly by controlling the style since LO is just using the style settings from SketchUp. The line weight is similar in that it is determined by the edge settings in the style. There is a “Line Weight” setting in the SketchUp inspector window but it is actually just a multiplier for the edge settings in the SU style. Non-profile edges (in normal, non-sketchy styles) are always 1 pixel wide in SU and Profiles are 1 px or wider depending on how you set them.

I can think of a couple of ways to create the appearance of lighter lines under your heavier edges but they involve stacking viewports with different styles or making multiple image exports and combining the raster images.


#5

OK, well, you have answered my question I think. No simple fix so probably best just to switch it off.


#6

At least until you’re ready to play. :slight_smile:


#7

@simoncbevans

I do think turning off the extensions in sketch up will help but not sure about that. Something else you can try if you are looking for a more rectified look is the following. Selected the view port in LO and in the Sketchup window hit the style tab, select the straight lines styles select the line thickness you want and switch to the vector instead of the raster. This should also bring back the missing line.