Difference between "Circular Cylinder" and "Polygonal Cylinder"


#1

Difference between “Circular Cylinder” and “Polygonal Cylinder”

Many People still wondering why there is no shortcut for ‘Polygon’ in Sketchup. I would suggest those to please view this tutorial which briefly describes difference between “Cylinder” and “Polygon” shapes.
Watch the video here: http://www.youtube.com/watch?v=if3AUzpBuaE


#2

Learn 9 Essential shortcuts just in 60 seconds

Watch another a quick briefed video tutorial of Sketchup containing 9 shortcuts applied to a model just in 60 seconds. http://www.youtube.com/watch?v=uOaMQ-Dqteg


#3

another difference with 2015 is that the polygon tool now has inscribed and circumscribed toggle with the option (mac) key… good addition.

fwiw, polygon has a default key shortcut on mac… ⌘;


#4

I assigned it “Y” on my keyboard using Preferences that is found under the Windows Tab. Sketch Up`s keyboard shortcut defaults can be seen by using the Alt key to highlight the Tabs shortcut key. Use arrows to scroll across to the Tab you need and hit enter. All the default SU keys are darkened and the ones you assign from the Preference selection are grayed. Take the time to use theirs and figuring out how to assign your own. Not only a time saver but builds your confidence as in remembering and utilizing all that is offered with this Software.


#5

Whether the shortcut appears dark or grayed out has nothing to do with who created it.
They’re dynamic, dependent upon model state/current operation.


#6

This has got me stumped: while polygonal cylinders look and behave the way shown in the vid, circular cylinders have dotted lines along their facet faces. And yes, they have just as many faces as the polygonal cyls, not just one.

Is this a new feature of 2015, a setting I have changed inadvertently, or am I missing something else?

Thanks, Peter.


#7

It looks like I have just answered my own question: turned off View > Hidden Geometry. Now my cylinders have one outside surface. :slight_smile:


#8

You have probably turned on Hidden Geometry (View menu).

SketchUp is a polygonal face modelling application, so there is no fundamental difference between a polygon and a circle. Both are segmented curves under the hood. When pulled into a 3D cylinder, the facets of a circle are by default smoothed. In Entity Info, a circle shows the correct area information, not the actual area of the polygonal face.

Anssi


#9

I think I understand that. Thanks!