Deperate for help with layout operating issue's

hello I’m new here and desperate for some help, I’ve been working with sketch up and layout for about 15 years but always on a mac and I’ve never had any issue’s with either SU or Layout, I recently decided to switch to a PC because I wanted to be able to use the D5 rendering program and other options not available on mac, I work for a large company that built me a custom machine based on a collogues machine that does very large projects and in general its much more powerful than any mac I’ve ever used, on the sketch up side of things it is amazing, but layout has been a major issue and is about 40% of the work I do, basically, any time I bring in a model and double click it to orbit the viewport or zoom in the model to do any kind of Drafting work it immediately freeze’s, no bug splat it just freeze’s and never recovers, these are file’s both of my old computers will run with no issue’s even my 12 year old travel underpowered macbook runs fine, I even made a test model of just a wall about 10’ w x 8’ high, no textures or anything, as light as you can make a model, same thing, it just freeze’s, from time to time it will work for a couple hours but in general its useless, we have a large IT dept. and they are baffled, I contacted SU help and they had me run the diagnostics and that checks out and says I should have zero issue’s, I’ve tried uninstalling and reinstalling the software, same thing, I feel like it has to be something stupid we are overlooking, has anyone had a similar issue? I’m desperate for help at this point, here’s my device specs,

I’m running windows 11 pro and a Nvidia Geforce RTX 4090 graphic card

processor 13th Gen Intel(R) Core™ i9-13900K 3.00 GHz

Installed RAM 128 GB (128 GB usable)

system type 64-bit operating system, x64-based processor

thanks so much for any help I can get!!!

when i’v eencountered something like this a few years back, i found altering the Preference → Graphics settings helped - i don’t remember if i tweaked the anti-aliasing or not, but i remember turning off the fast feedback and maximum texture size.


thanks so much I’ll give that a try, I appreciate the help