Dashed line styles not appearing accurate in LayOut

Yesterday I thought I’d add dashes to a project in Sketchup using the new dashed line type instead of drawing them in LayOut. When I went into LayOut, I noticed the dashes aren’t appearing the same as in the SketchUp model, they are becoming longer and less frequent in LayOut. This were a bit unfortunate really as I thought they looked really good in SketchUp but became “larger” than I wanted in Layout.

I can’t share the project publicly, so I just put a quickie together using basic templates to show what I mean and the difference.

SketchUp model: (It’s the shorter one I liked)

LayOut file: (The dashes aren’t accurate with the model)

Although it doesn’t look too bad in this example, the other project were quite intricate and ended up not quite what I wanted because of the longer dashes.

Is this intended or has anyone else noticed this?

I’ve noticed this and I believe it is related to how the viewport is sized. You can change the scaling of the dashed lines by clicking on the drop down that says “Auto” and changing the setting. It’s basically the same idea as in Shape Style. The line weight can of course be set, too, and it will affect the appearance of the dashes.

Hi Dave, thanks for the reply.

I do find it strange that the dashes appear that way, I would think they would appear the same but it does seem they are scaled in some way.

I see that can be adjusted, it’s not normally something I would look at because of the way I’m used to drawing dashes in LO setup within my template.

I didn’t do this for the love of time. But in that case I’m guessing I’d be better of creating a scene with just the dashes and stacking that viewport on top of the main model viewport. That way I can adjust the dashes without affecting the appearance of the model edges themselves?

The Auto scale thing for dashes tries to make them look reasonable based on the size of the viewport but they do give you the option to change it just as you can with dashed lines in Shape Style.

I always create a separate scene for just the dashes in LO and stack the viewports because I rarely ever want the dashes to have the same weight as the non-dashed lines.

1 Like

Yes my dashes are always a lighter lineweight, I completely overlooked that in this case.

I do like the SU dashed lines, I find them much easier to draw in SU. I just need a slight change to how I’m doing things.

Thanks for the advice, onwards and upwards…

1 Like

I also like how simple it makes showing hidden lines such as mortises and other joinery. Same components, two scenes, two styles and you’re cooking with gas.

1 Like

I tend to avoid stacking viewports for whatever reason, maybe due my limited use of LayOut it gets me confused. The new linestyles have just completely thrown me with the dashed lines. I would like to advance things a little more though. Is there a chance you could elaborate a little with maybe some kind of simple example that shows this with the styles used etc, to get this thing stuck in my head?

No worries if you have bigger fish to fry though.

I’ll work something up to show you.

Let’s see if this helps, Ian.

In SketchUp I set up dashes for the layer(s) associated with the components for which I’ll want to show hidden lines. I have two styles set up. One with Dashes turned off, the other with dashes turned on AND the Face Style set to Wireframe. Using the first style with Dashes turned off, I create a scene showing the components.

Then I choose the style with the dashes turned on, turn off layers I don’t need to see in the scene and create another scene with the same camera position.

When I send to LayOut, I set up a viewport showing the scene without the dashes. It goes on the lowest “model” layer. (My templates have between 3 and 6 model layers.) When I have the viewport scale set correctly and its position on the page established, I copy the viewport, make the next layer up the active one, right click in the main window and choose Paste to current layer from the Context menu. I immediately change the viewport to the dashed line scene. I end up with the illustration in the center of the page. I copied the viewports to the left to show each one individually.
Screenshot%20-%203_21_2019%20%2C%207_57_11%20PM

You can adjust line weight and the dashes scale in the SketchUp Model panel to suit. Here’s a closer view of just the door.
Screenshot%20-%203_21_2019%20%2C%207_57_36%20PM

Since these viewports are both still tied to their scenes, if I need to modify the hidden details such as add haunches to the tenons or make them through tenons, All I have to do is edit the components in the model, save the changes and update the reference.

Screenshot%20-%203_21_2019%20%2C%208_17_01%20PM

A couple of important points to keep in mind. A layer for each viewport in the stack. Do not modify the scenes in LayOut (for numerous reasons). Simple Copy and Paste to current layer to keep everything aligned. Don’t move viewports around unless you move the entire stack. If for some reason you need to access a viewport down in the stack, lock the other layers and even turn off their visibility so you can easily get at the one you want.

I find this works quite well and it’s much easier to keep straight and much less work when the inevitable changes come along than manually created the dashed lines in LO.

3 Likes

Thanks for the excellent description it is very helpful, you’re very generous with your time and knowledge.

I think the main thing I couldn’t get my head around were how to use the same component but show it both dashed and default using the new line types. The nail on my head were when you said:

I forgot about the new dash toggle of styles. I Switched up my in model styles a little as you suggested and then just put something together to figure it out…

This one is two scenes stacked with the styles as you suggested…

Capture

This one is two scenes stacked with the styles as you suggested and then a third on the top with just edges made into a component and assigned on a “dashed lines” layer…

I’m finding the control over the dashes quite impressive in LayOut and simple to adjust in bulk too. This method has to be better than the other one I’m used to by tracing the edges in LayOut, as you say the dashes are actually live and change with the model. Also I imagine dimensions for these areas will be easier as you are picking up model endpoints you can see and not having to dodge scaled layout dashed lines that give inaccurate dimensions.

Obviously a bit more practise will go a long way, but I reckon I’ve just about got it, hopefully.

2 Likes

I thought about this and became concerned that “rounded” parts like holes and rounded mortises that I use wouldn’t show up using dashed lines style as there is no real “edge” to display the dashed lines.

But they too come through perfectly, I wouldn’t have thought those borders would show. I suddenly feel like I’ve rediscovered the wheel, after everyone else. :grinning:

1 Like

Glad to hear of your successes.

In case it’s of any interest, the difference in sizing of the dashes between SketchUp and LayOut is 100% to do with the paper size and screen size not being 1:1 (LayOut documents are effectively zoomed in or out compared to SketchUp).

The dashes certainly are designed to match perfectly between the two, and it sounds like you’ve found the dash scale control!

Out of curiosity, what scale did you end up changing it to afterwards?

Unfortunately I don’t remember and I didn’t save those files. I guess its kind of moot because depending on the parts I might have different scales on the same page, using my own judgement to choose, as the table leg sample above shows. I did that when I drew the dashes in LayOut too.

But, I just knocked up another one similar to my first post with just one dash style. In the model there are 31 dashes on the edge. When I drop that viewport straight into LayOut as it is without resizing it, there are only 10 dashes. I then changed the Line Scale to 0.3pt and 0.75x and that gives 26 dashes, that’s very close.

Although, when the viewport is a different scale the dashes are scaled differently too. And if a different paper size is used then I guess it would be different again. Here’s that little tester anyway:

DASH.layout (67.6 KB)

I’m actually happy with the way things have panned out. In the way I can draw any dashes in SketchUp that require drawing and I can also make use of the method Dave superbly outlined to me to save drawing many of those dashes manually in Layout anyway. By stacking viewports the level of control is impressive. I think the main issue were me, getting my head round it.