DAE export issue, scrambled, transparent textures

I have this file that looks fine within sketchup but when exported to .DAE it shows transparent textures even though there is no transparency set to the texture. If I use C4D or UE4 it still shows the transparency and some parts have scrambled textures. The issue carries over to any file convertion of the original exported sketchup .DAE file. Its odd since yesterday the file was being exported fine and it was working with all the other programs, I must have modified something within the model that caused this. What can it be ?

I included this image showing my results.

thanks in advance.

Pls, post the model as an attachment.

Purge first via Window > ModelInfo > Statistics > Purge Unused

Then attach via either the 7th button on post edit toolbar, or drag and drop the file into the post message field.

ADD: Looking at your material name “<auto> 51”, this may cause issues, as DAE is an XML format. That “<auto>” part of the name, looks like an xml tag and might confuse applications trying to read the file.
I don’t think using these symbols in names is a good idea (for DAE export.) Try using other bracket symbols, if you can.

Well the obvious thing to check is the export options settings that are set via the “Options…” button at the bottom-right of the “Export” file dialog.

‘Entity Info’ is showing a ‘Surface’ with a ? mark for the back texture…

how have you managed to do that?


part test1.skp (2.1 MB) Here is the file. I tried exporting to DAE with every option I could and I still got the same results. I also removed the tags as you mentioned, same result.

I’m not sure but by clicking on the model and reassigning the paint texture got rid of the question mark, but the model is still behaving the same way when exported.

I exported to DAE, then re-imported that in a new blank model. Textures look fine (after I switched off X-ray mode.)