Cutting miters

I have a component, a piece of molding, and 2 groups used to cut miters. I’ve done this many times in the past but today it’s not working. Explode, Intersect Faces, delete unwanted. Am able to delete one end of the component but deleting the other end deletes part of the body of the component.
miter.skp (187.9 KB)

after exploding and intersecting there is a very small line missing between the molding and the cutter on the right hand side. draw it in manually and that solves the problem…

Thanks! I found that too, do you know what causes that?

It’s due to the extremely short distance. Intersect doesn’t pick it and create the line. It’s right on the edge of being to small to create at this size. Probably a few more segments in the curve than you really need for a piece of molding.


Or use the “Dave-method”
The reason it doesn’t work is because the intersect with command has to draw a line that is too short, so it doesn’t.

stangely the other side does intersect normally, while the molding is the same on that side…

Yes it does.

When you are working close to SketchUp’s small edge tolerance, minute computer arithmetic effects can cause one case to work and a similar-looking one to fail.

1 Like

I downloaded the molding from the warehouse, to see if I could modify it to make a picture frame, look feasible. And I learned something new, again.

1 Like

I’m still having problems with cutting miters. I made a new molding base on something I had in my workshop to make a picture frame, this molding is a chair rail.

The only way I could cut the miter, especially the right one, was to scale it up by 1000, no problem easy to do. I scaled it back down and now there is another problem, I’ve included the model so you can see what I’m talking about. I saved it, thinking a new instance of SketchUp would clear up the problem, it didn’t. Zoom extents does this:

chair rail3.skp (386.6 KB)

You are seeing clipping due to some large geometry at a great distance from the rest. Turn on Hidden Geometry and hit Zoom Extents. You’ll see them. Erase them and you should find you can zoom in to the molding just fine. Also, because you’ve scaled the component instead of the geometry inside it, you need to correct the defintion’s scale. Right click on it and choose Scale Definition.

Thanks Dave.

More related questions:
What are those lines left over from the scaling?

After scaling something up, what’s the trick to getting scaled back down in the right place?

I’m not sure what you had that left those edge segments in your model.

The short answer is to grab the same scale handle for scaling down that you used for scaling up.

It looks to me as if you might have scaled up a component and exploded it to work on it before scaling back down. and made a component before scaling down or you scaled up after opening the component for editing but didn’t open it for editing when scaling back down.

I know we’ve talked about this before but the “Dave Method” eliminates the issue of getting the scaled up component back into the right location. You scale up a copy of the component, edit it and when you are finished, close the giant copy and delete it. Zoom back in to the original. It’ll be where you left it and it’ll have the modifications.

I use the “Dave Method” all the time, but I don’t think it works with Intersect Faces, am I wrong?

It does work with Intersect Faces. That’s one of the key reasons I use it.

1 Like

It work fine with intersect faces. I find the easiest workflow is:

  1. Draw the cutting planes in the general model context (i.e. don’t open the component for edit yet). Move and rotate the cutters as necessary to place them where you want the miters
  2. Cut the plane to the clipboard
  3. Open the component for edit
  4. Do edit->Paste in Place to put copies of the planes into the component context
  5. Close the component
    (here begins the “Dave method”)
  6. Make a copy of the component off to the side
  7. Scale the copy by a suitable amount
  8. Open the copy for edit
  9. Select a suitable subset of the component’s contents to limit what intersect has to process
  10. Right-click Intersect Faces With…Selection
  11. Clean up the unwanted stuff
  12. close the component
  13. Delete the scaled up copy
  14. Zoom extents to see your original again
1 Like

Thank you gentlemen!

When I learned about Intersect Faces, this is what I wrote so I wouldn’t forget:
“Interface Faces: both are groups or components, then explode both and delete unwanted!” This is so much more elegant.

And the point is if they are contained within the component being used for the Dave method it works.

How about using a different method? - YouTube

@kimrebley, that’s the same method. Only the way the cutting plane is obtained is different.