Custom toolbar extensions problems

I am trying to make custom toolbars from my different extensions, using either LordOfTheToolbars from @fredo6 or the toolbar editor from @Aerilius. Both of them have problems, does anyone know of any solutions to them?

The problem with Lord of the Toolbars is that none of the toolbars get locked in place, every time I open sketchup I have to reposition them. I also got an error message when installing it, see screenshot

With the toolbar editor, the problem is that if I start up sketchup when I am not connected to the internet, some of the icons do not appear anymore (for example solid inspector), not in the toolbar, or in the toolbar editing dialog.

I have uninstalled and reinstalled both plugins, both libfredo and lott are up to date, I have run sketchup as admin and repaired the installation, and nothing changed. anyone have any ideas?

(Thanks in advance)

@fredo6, do you have any ideas what this problem with lott is? the same error appeared when I installed HoverSelect, although I don’t think that caused any problems for me. (I tried it out, and decided I didn’t want to keep it, but in that brief time trying it out I did not notice any problems.)

That’s a recurring and random problem which I have difficulty to identify the source. It derives from a bug in Sketchup, never fixed, about menus.
Currently, I don’t know what I can do.

This would indicate the those extensions are not loading, so their UI::Command objects are not loaded. Toolbar Editor needs command objects to list in it’s dialog.

This might be because they need the internet to verify their license or some other fact such as load policy. What policy do you have set in the Extension Manager ?

Also make sure you do not have any old version of LOTT or Solid Inspector lurking around in your “Plugins” folder.

Okay, thanks for letting me know.

These extensions’ regular toolbar loads fine, it is only in toolbar editor that it doesn’t, does that change anything, or not? (I don’t know coding at all, so I have no clue how these things work.)

It is set to unrestricted.

I don’t think so, but I don’t know how to check. Other extensions that don’t show up are vbo to level and vbo back to root.

Well they were just guesses. I haven’t delved into the Toolbar Editor code in years and I haven’t much time lately to try to test.

If what Fredo says is true about a random bug, then it’s not much that can be done by the extension authors.

Question, are you running both LOTT and Toolbar Editor ?

I am currently using both, Toolbar editor to make custom toolbars (from the icons that work) that stay in place, and LOTT for the vignette strip, although each time I open sketchup I need to close the LOTT toolbar.
Thank you for your time, and thinking to myself now, maybe I should just make instead of custom toolbars, a pallete for each toolbar.

The reason I ask is that both extensions are “hotwiring” API classes and if not careful this could give each other issues. Not to say that this is definitely the problem nor that the authors did not take care. Just that it’s a possibility.

I have tried each one without the other, so I don’t think this is the problem, but thanks for your input.

1 Like

I have updated to Sketchup 2023, and the error message for LOTT has gone away, as well as it seems that the toolbars are staying in place, so my problems are solved.
however there is some other problems, Fullscreen mode does not appear, and I cannot make custom buttons for menu items.

This is correct…

Due to the change of UI framework in the Windows version of Sketchup 2023, I had to remove:

  • The Clean Screen feature altogether
  • Everything which is based on Menus (custom Menu commands and Find among menu items)

Unfortunately, there was no workaround (despite requests for new API methods to the Sketchup team).

I was able to save the rest of LOTT, but still discover issues. I just fixed one in LibFredo6 v13.9a, just published.

Sorry for inconvenience

okay, thank you for your help, and it is very useful even without these features.

I made a bunch of custom Icons and they wont load back as icons for my "favorite “tabs”