Ctrl-key and Shift-key changes with new update

Hi,

Ever since I’ve updates Sketchup 2021 to the newest version my Ctrl-key is set up differently.

Before, when I would press CTRL-key whilst in the ‘move’-modus it would immediately add a little ‘+’ to the cursor and the component or group would be copied when moved. If I would let go of the CTRL-key, it would just act as a normal ‘move’.

Now, with the update, it seems that I first have to press the CTRL-key, let the key go, then the cursor adds a little ‘+’. After copy+moving the group or component the ‘+’ stays. I have to press&release CTRL again to go out of this mode.

In polite terms, this is extremely annoying. I loved that just by pressing M+CTRL I could ‘copy’ components and not worry about it once I released the CTRL-key. But now I’ve copied more than I would like to, or not copied at all (because I’m used to keeping the CTRL pressed down whilst copy+moving objects). The logic of this also fails me. If it’s not broken, why fix it? And if this is a fix: How is this supposed to help my productivity or workflow? It comes across as more of a hassle.

Is there any way I can go back to the setup as it was with the older version? Or am I missing a setting that I have activated by accident?

Thank you for your answers.

Daan

You’re not alone.
There are similar topics about the “issue”.
More users don’t like it. (At least more people write posts that they don’t like.)

Here is a blog post, that may help you to survive until SU team maybe come with some solution…

1 Like

Thanks Dezmo. For a moment I thought I was going crazy but in a way it’s a relief that I’m not the only one.

I agree with you both here and this “toggle on, toggle off” requires an additional keystroke vs just holding cntrl for a split second to actually make one copy. This change is good if you wish to make several copies without having to continuously re-click the cntrl button, however, if you only want to make one copy and then move the copied item straight away, you have to “toggle off” by clicking the cntrl.