Control key to Copy isn't working right

In the past few days, when I hold down Control and click to make a copy, sometimes it works fine, but most of the time the “+” sign doesn’t appear and I have to click first, then hold down Control and click a second time. This is very frustrating. Is anyone else having this problem?

What version of SketchUp are you using? Please complete your profile.

If you are using SketchUp 2021.1 don’t hold Ctrl. Press and release.

Read the release notes to see what else has changed.
https://help.sketchup.com/en/release-notes/sketchup-desktop-20211

I have updated my profile as you requested. I am using the latest 21.1.299 version of Sketchup Pro. When I hit the Control key to copy, the “+” sign appears about half the time. The other half of the time, it doesn’t work and I have to right click to cancel the operation. Then, when I hit Control the second time, the “+” sign does appear. This is very frustrating.

Isn’t the latest, this bug was fixed in 21.1.332

I just downloaded the latest version. However, I also discovered why things weren’t working for me before (and even now with the latest version). When I highlight an object, then hit the Move tool and Control, the “+” sign doesn’t appear. I must first click on the highlighted object before hitting Control. It seems like in past versions, I didn’t have to click on the highlighted object…just highlight, hit Move and Control.

Oh, well. Now I know what I have to do. Thanks.

That’s not correct. You should not need to do that. Here I’m showing getting the Move tool and invoking Copy by tapping Ctrl without anything pre-selected.
move

And now with two taps of Ctrl you get the Stamp option which places copies where you click until you either change tools, hit ctrl again to stop stamping or hit Esc.
stamp

Perhaps you need to do a repair of your installation.
Using the new install file you just downloaded, right click on it and select Run as Administrator, then choose repair when given the option.

1 Like

Dave, I did as Box suggested and Ran as Administrator to do a repair of the new file. But, when I opened Sketchup, it still doesn’t do right. I have to highlight the item before I can copy it. I am attaching my file to show you.Scenes Test.skp (1.0 MB)

Well, it works fine for me.

movecopy

Dang! Could it be a problem with the Control key on my keyboard? Maybe I’ll try another keyboard to see.

Might be. I wore out the Ctrl and Shift keys on the left side of my last keyboard. Even wore off the labels. Wore off the feet on the bottom of my previous mouse, too.

Well, I tried copying on my laptop just to see if it’s the keyboard problem. It was doing the same thing on my laptop so I FINALLY figured out what the problem is. When I hit the Move tool, if I don’t click the mouse first before hitting Control, it doesn’t copy. If I click the mouse, then Control, all is good. I’ll swear it didn’t used to be that way. Before, when I hit Move, then Control, the “+” sign came on.

Something still seems weird on your end. It doesn’t work that way for me. It doesn’t matter whether I select the Move tool from the tool bar or just use the keyboard shortcut to activate it, once I have the Move tool pressing Ctrl activates Copy.

Here I’m not even touching the mouse until I move the cursor over to the component to select it for moving. I did it all kind of slowly to show the steps.
movecopy

Is it possible that SketchUp isn’t the active application when you do this? I can make what you describe happen if I have the Move tool in SketchUp but first make a different application active berfore coming back to SketchUp. I just did that after clicking on an application on my other screen.

I think you’ll both find that you are doing it slightly differently.
Tap and hold and tap and release.
My guess Munionman is tap and hold and Dave is tap and release.

1 Like