Creating Template causes Windows error - load as administrator?

I wanted to create a simple template with a white ground , metric and no textures by default:

  1. Loaded a base 1. template then applied required changes

  2. Save as Template…

  3. I get a ‘Do you want to allow the following program to make changes…’ the program is said to be ‘Windows Command Processor’, although the details do show refernce to Sketchup progam files location.

  4. I didn’t like this so for safety cancelled then…

  5. Sketchup error reported: " CFileException 2 in C:\Program Files\Sketup\Sketchup 2016\Resources\en-US\Templates_BasicSimpleTemplate.skp

After some testing I find that loading as administrator removes this error and the template is created and saved successfully. Whilst I can understand this I think Sketchup showing the error message it did will be alarming for some users, wouldn’t it be better to show something like ‘User cancelled request’ and also shouldn’t the user be warned that you need to be either in Administrator mode or you will have to say ‘yes’ to ‘make changes’?

So this isn’t a question as much as a suggestion it needs thinking about and I didn’t know where else to note this.

liz

1 Like

If you install SketchUp using Run as administrator, you won’t need to jump through those hoops. Try this:

  1. Quit SketchUp.
  2. Find the installer file you downloaded.
  3. Right click on it and choose Run as administrator.
  4. When presented with the options window, choose Repair.
  5. After it completes the installation, do a cold reboot to make sure setting changes get made. Shut the computer off and restart it. This step may or may not be required but it can’t hurt.

Then use your normal login and see how it goes.

Hi Dave,
Thanks for helping. I did as you said but to no avail. However I fear should have siad that I was using a 2016 install package because the 2017 installation kept failing. However the PC is now up to date with all Windows updates (there were over 200 outstanding as it had not been used for a while! So I thought I would try installing 2017 again.

Bingo, all works beautifully now, thank you… liz

1 Like

This topic was automatically closed 91 days after the last reply. New replies are no longer allowed.