Sketchup only crashes on non-administrator user

crash

#1

As above. I’ve just installed a clean copy of sketchup 2015 trial on one user’s workstation. Everytime we try to launch sketchup using his account (normal users group account), the software crashes. However it launched without error using the administrator account.

Anyone faced similar issues ?


#2

update:

I created a new user account on the PC, sketchup launched without any issue in the new account. So I think the problem is somehow linked to the user profile.


#3

What windows version do you use?


#4

Windows 7 64 bit. Still skeptical about Windows 10


#5

Did you use ‘run as administrator’ when installing SketchUp from the installation-exe ?
If not some aspects can be flaky.
You can always reinstall it that way…
[Select the exe and right-click > Context-menu > Run as administrator…]

Also, find the SketchUp.exe that is installed, highlight it and use the right-click Context-menu > Properties > Compatibility, and tick the check-box that says something like ‘always run this program as an administrator…’ ?

Both or one of these fixes should give a more stable installation…


#6

Yes I did. Initially I installed using the administrator account. After that I uninstalled and tried to install from the user account by using ‘run as administrator’. Both return the same result.

The only solution I have now is to create a new user profile in windows and run sketchup in the new user account. Somehow sketchup only crashes when I run the software in the user’s old user account in windows.


#7

@v1ncent87, what is the behaviour for LayOut?

Also, please check if the user profile allows writing to C:\ProgramData\SketchUp\SketchUp 2015 folder as sometimes access to this folder can cause this problem.

Yogesh