Creating section plane is consuming CPU and is very slow

hello everyone, please give me a hand.

I started using the cutting tool (section plan) a lot more, but in all files, from simple (50mb) to more detailed (500mb) starting a cut is a horrible pressure on the computer for a while and then it normalizes, the expense of the CPU considerably and then it normalizes and everything is normal.

After making the cut if I want to adjust it too, changing the position, he locks again and stays there thinking with all his strength and then stops. I found out by digging a little more than when disabling this option “solid section” when clicking with the right button on the cut this allows me to move the cut already made without locking.

corte abençoado

But what can I do to help sketchup not get stuck like that? So many videos of people making cuts in seconds and I can’t do it.

Machine config:

Win10 i7 SSD250gb 16gbRAM GTX1070

Sketchup Pro 2019

sorry my english, Im Brazilian.

I would say that 50 mb is not a small file. 500mb is a really big file. I think you should think seriously about how to reduce file sizes. All details that are there when you zoom in but will not be really visible in the scale you actually present your work should go away. They just slow you down, and have no benefits to the result. Materials should be simplified. Dont put materials on anything where you could just as well use a solid color. You should use simpler placeholder symbols for things like the bed, so that you dont have to do your work looking at those detailed components. Also, purge your file for unused geometry. Its a lot more fun to work with a responsive computer.

hello, thanks for answering me.
I understand that 50mb is a heavy file too, but that’s how I work for years, in previous versions, 2015, even in very heavy files, 300mb, I was able to make a quick cut. That’s what I don’t understand, what happened to be like this, and 50mb is a light file, which is the custom here. The demand for quality is very high, unfortunately.

I already did all these procedures also just to test and even so, leaving it all simple, even with the materials in low quality, it took the same time to cut.

The last three context menu items are not native, so perhaps it is Dibac that is causing the issue. Have you tried with that disabled.

Hello, how is everything? apologies for the delay!
I just tested it, consumed a little less and it was a little faster too, I think I will deactivate more of the ones I usually use so to help more. If this resolves, I will return here! Thank you for your support!