Crashing using BoolTools

As usual, need to finish job urgently!!!
Have been using BoolTools throughout the model until it crashed on one hole. Now every attempt results in a crash. Have eliminated other holes but still crashes.
Native solid tools simply doesn’t cut through.
File is here

Scale, scale up or use the Dave method.

By “crash” do you mean that BoolTools fails to complete the operation, or that it crashes SketchUp?

Almost all the time, BoolTools runs flawlessly for me. But I’ve seen situations in which it fails, typically during a subtract or trim where the “cutter” touches the “cuttee” along an edge. I’ve also seen it mysteriously work fine on one hole and then hang forever on a second identical one. I guess nothing is perfect…

When you get time, you might contact MindSight Studios to see if they have any insight into your particular case. You may have found a bug they can fix.

1 Like

SketchUp crashes, and native solid tools fails to complete the operation.
Unfortunately I don’t have the luxury of time, my client is to inspect their prototype in the morning, so with several hours of printing to come I need a solution urgently.

Box gave you two solutions that will work immediately.

I used the Dave Method with no problem.

when I model detailed stuff for 3D printing I model as if millimeters were meters and leave it big. That avoids the tiny face issue. When the .stl is exported the units are set to meters and then it is imported into the slicer as millimeters.

Box! It’s so aggravating how simple you can make things seem. Thanks again for saving my bacon. If it weren’t for fear of being quarantined on the way back I come down and paddle out there with more than one beer.

Dave, I usually do exactly that. But with it was too confusing for me having to work out all the threads needed. I thought I had the faces under control - obviously not. Thanks for chiming in.

If you are modeling with units set to meters there’s no extra math required. Thread pitch is 1.0 meter instead of 1.0 mm but it’s still just entering ‘1’. The screw diameters are still just 9 and 12.

I am having issues with BoolTools 2 using the trim function. I purchased this months ago and it worked really well. So much so I recommended to a friend recently for purchase. As it happens, the last couple of days some strange things have been happening.

In the attached file called booltools2 tenon test when I trim the leg with the upper tenon, it removes a mortise face, making the leg no longer a solid.

In the second attached file, dovetailed box_ booltools test, trim and selecting the side component first, then the front component, Sketchup hangs (beachball ) for minutes until I do a force quite. Other times I have seen Sketechup crash.

In other cases, not in either of the attached files, I have seen faces removed after the trim. Another case, the trim component turned dark gray and I wasn’t able to zoom extents. After trying to gain control of SU and view the model, the trimmed components were deleted, with undo not working to restore them.

I have installed and reinstalled the BoolsTools2 extension but no difference. The attached files use simple components without creation of small geometry.

In the case of the attached files, using the Trim and Keep extension works fine for doing the same operations.
Any help is appreciated.

booltools2 tenon test.skp (1.1 MB)

dovetailed box_ booltools test.skp (774.3 KB)

Not sure what’s going on for you with the tenon example.

I do see the slowdown with the dovetails which is odd. I wonder if @Whaat would have any suggestions.

Thanks for checking the files and pinging @Whaat. Hopefully he can have a look. There is a bugsplat crash report #356350 which maybe of some help if he can get access to it.
Strange this just started happening to me in the last couple of days. Its been a very reliable extension for the time I have used it.

I redrew those parts in a new model. Well except for the back. Trim worked Flawlessly. I wonder if there’s a problem due to the geometry at the other end of the sides.

Edit: Nope. I don’t think that’s the reason.

What method did you use to create those parts and the dovetails? I drew new parts in your model file and used Trim and there was no delay.

FYI, The joinery cut into the side using the back component was done using Trim and Keep.
I tried to redraw the components and use BoolTools to trim and as shown, one face of the side was left deleted afterwards.

I tried redrawing something similar in a seperate file and it worked fine.
For the post and tenon file, if I redraw the tenons they work fine.
Too many of these issues happening where Trim and Keep works fine but BoolTools deletes faces or worse. Just glad I didnt remove Trim and Keep.

Very odd because I can’t reproduce this when I draw the components myself.

I drew rectangles on the red/green plane 3/8" thick x length, push pulled up to height. Then made components of side, back and front. I tried Woodwurx plugin but it didnt work for these handcut spacings, so I undid. Then I defined the pins on the end of the front and back components using the protractor and lines to draw a pin then move/copied them down as needed. Pushed pulled to 3/8".

If I copy the side and front components from my previous post where the face was removed and paste them into a new file, then do a BoolTools Trim. This time it completed but
I get a message about very small geometry and would I like BoolTools to correct. When I view the hidden geometry it looks like below.

Something isn’t planar, do you have length snapping turned on in Model Info/Units ? If so turn it off as it only creates problems.

Length snapping is turned off.
The hidden lines or the missing faces only appear after the BoolsTools2 Trim completes.
Using a copy of the same parts using Trim and Keep doesnt result in the hidden lines or missing geometry.

I’ll leave you with Dave on this as I don’t use either tool.