Crash and shutdown after 15 secs

Every time I start using sketchup today it just randomly shuts down. It has been working fine up until this point. I have tried uninstalling and reinstalling but no effect.

Can anyone help please?

Are you getting and sending Bug Splats?

Immediately after opening SketchUp, go to Window>Preferences>OpenGL. Disable Hardware Acceleration. Quit SketchUp and reopen it. Does the crashing stop? If it does, try updating the drivers for your graphics card. It may or may not help. AMD Radeon cards such as you’ve listed are well-known to be lacking in adequate support for OpenGL.

using the 32-bit version of SketchUp may help in this context too.

the other big source of crashes are old plugins/extensions, if anything installed newly in this area try if disabling the regarding plugin/extension helps (“Window > Preferences > Extensions…”).


Hi Dave thanks for replying.

Yes i have been sending bug splats.

Ill give your suggestion a try and get back to you.

Just tried Dave’s suggestion.

This is the bug splat report:
Bug splat report
Crash Report #189834

Ed, there are a couple of other things that seem to have helped some users with AMD Radeon cards and Windows 10.

First, rolling back the graphics drivers to an earlier version–maybe a couple of versions back.

Second, as sketch3d_de suggested, switching to 32-bit SketchUp.

Maybe a combination of the two.

Or maybe replacing the GPU with an nVidia GeForce card. We aren’t seeing reports of crashing from users with GeForce cards.

This Help Article may be of some interest.

Thanks Dave.

I also have a nvidia GeForce GT440 running.

I recently updated my AMD drivers as i was having performance issues.

I will try switching to sketchup 32bit and see what happens

Im trying to install 32bit sketchup but its now telling me my license is expired.

Are you installing SU2016? Did you find the e-mail with the license info for SU2016 and enter it into SU?

I just heard from another fellow I’ve been helping with the same sort of problem. He said an app called PlayTV was installed with a driver update for his AMD Radeon card. Removing that app stopped the crashing. Might be worth checking that out.

Hi all-

Crash report #189834 is one that I haven’t seen before. The crash is in a routine named “ltc_game64”. SketchUp has NEVER crashed in this place before until July 1, 2016 (10 days ago) and since then it has crashed 147 times.

I’m guessing that some new software came out that’s causing this issue - OS upgrade? Recently released game?


Marc, see my post above yours. It seems there was an update that Windows pushed out which included an app called It seems to have only gone to computers with AMD radeon cards and it seems to be the culprit. Removing it has stopped the crashes.

@Marc have a look here.

That’s exactly it. is a joint venture with Raptr, and this particular library is from them.

We’ll add a message to the Bugsplat reporter for this issue that mentions the problem.


1 Like