Copying and pasting object into existing model

I’ve downloaded some objects from the Warehouse, save them to my HD then open them, copy them and go to my main model and paste. I see my cursor “flash” momentarily as if it’s pasting the copied model but the pasted model isn’t visible in my model. I’ve done this now with a wooden ladder, a wooden crate, and I can’t see them in my model. I get no error message or anything.

I can’t download them directly into my model because I get the Mac spinning beach ball for several minutes and have to force quit SKP. So I’ve been saving them to my HD then open them and copy them.

Frustrating…what am I missing? I’m using SKP 2020 Version 20.0.362 Any ideas as to what I might be doing wrong?

Can you share the ladder model file and the .skp file you’re trying to paste it into? If we can see the files you’re working with we can certainly figure out what you are missing.

I sometimes see the same thing, also on Mac (Mojave) in SU 2020 too.

Look in the Component Browser. You can usually see them there.

Or use File/Import/ Sketchup (.skp) from your hard disk Downloads folder into your main model, instead of copy and paste.

The main model is around 97MB’s. Can I upload something that large via the forum? The wooden crate.skp is real small. That’s the model I’m trying to paste into the big oneWoodenCrate.skp (195.8 KB)


Tried your file/import suggestion; (see screenshot). The file I’m trying to import is greyed out in the Finder window at the very bottom of the list “wooden crate.skp”. Could that be indicative of another issue? It does have the .skp file extension after it like the rest but some are greyed out and some not…?

After just posting the previous I went back to SKP and lo and behold the file was no longer greyed out. Hit “import” and got this error message: (screenshot) Screen Shot 2020-04-22 at 10.57.37 AM|690x371

97Mb seems kind of huge for what you show. Try purging unused stuff from the file (Window>Model Info>Statistics.) and see what you get. Then upload the file to Drop Box and share the link.

Will do. Thanks.


Also just got “file not found or invalid” with this downloaded model from Warehouse when using file/import.wooden bowls.skp (398.9 KB)

Your cabin model has some issue. You’ve got the field of view set extremely wide which will make it difficult to work. You’ve got the axes screwed up which will make it hard to insert elements into the model with the correct orientation.

After resetting the axes, it’s possible to see that your model is positioned off axis.

I was able able to copy and paste your crate model with no problem, though.

You would find it easier to work in SketchUp if you don’t turn off edges in the style and it would be a good idea to keep up on maintaining proper face orientation. Blue faces are back faces and shouldn’t be exposed in the 3D model.

So back to your original issue, what happens when you try to paste the crate component into your cabin model now that you’ve simplified it?

Thanks for all the helpful advice Dave. I reset my axis and FOV for the model and turned on edges and profiles. Still getting error message when I try to import the crate file and when I try to copy and paste it my cursor turns into a 4 headed arrow for a sec then no object is pasted that I can see.

1 Like

What error message? You wrote earlier:

Strange. Just imported it and this time it loaded into the model. No error message. Guess problem solved. Thanks for all your help Dave.

1 Like

FWIW Copy and paste and import (dwg etc) are VERY slow on the Mac.
Good idea, as you do, to open 3d warehouse models into a separate blank file first. Clean them up before putting into your model.
Import places the object at the axis and paste places the object at your cursor (for you to click an insertion point).

Thanks pbacot! I didn’t know that about importing and pasting as far as orientation.