Copy Edges Odd Behaviour

I thought I’d post this here as this has always been an issue with “out of the box SketchUp”. I’ve included a video of the problem, which doesn’t happen when using an extension like Edge Tools>Split Faces, only when trying to copy an edge using native tools. The basic breakdown is this:

  1. Create a Rectangle on the ground plane (say for a base cabinet of size 24"x24")
  2. Use Push/Pull to pull it up to a height (say counter height of 36")
  3. Copy the bottom front edge up (say to the height of a standard 4" kick)
  4. Use Push/Pull again to push the kick in (say 3")
  5. Select an upper side edge and try to copy it in (say 6") using the Move tool
  6. The edge isn’t copied unless I type 6" again (or any dimension)

As I said this works as expected only if you use extensions and consistently reproduced. It would be nice if it could be corrected. It has occurred in other instances as well but I know this one above is an effective example of the issue.

I don’t see that behavior here. This is in SU2021.1.

Found out why, try it using the number keys on the number key pad as opposed to the numbers above the letters. It does work if you use the top numbers but not if you use the keypad.

The number pad input doesn’t work on 2021.1 either, but does with the top number row. Better if it worked with the number pad :wink:

Spoke too soon. It did work for a couple of times more now it’s not.

Update! If you toggle copy BEFORE selecting the edge it works, if you SELECT the edge first (which is my workflow) THEN toggle copy it exhibits the behavior. After the first edge is copied, you can select and toggle any other edges without issue. Glad to have this dialogue to hone in and identify the issue, thanks DaveR

That being said I’m hopeful it may be looked at in the future as it feels inconsistent since the toggle concept becomes a specific sequence in this case, not a simple toggle on/off when needed.

Have you pressed the Num Lock key so that your numeric keypad input non numeric characters or codes?

I was using the number keypad. I always use the number keypad.

Hi Jean_lemiere_1

After seeing what DaveR was doing and more evaluation, the issue is the order in which you toggle copy. If you use the Move tool and highlight the edge and select it, THEN toggle the Ctrl key it won’t allow you to create the copy with a numerical input. BUT if you use the Move tool and toggle the Ctrl key BEFORE you select the edge it will allow you to copy it with a numerical input. This is more in line with the sticky modifiers which I still need to get use to. I must have sequenced the Ctrl toggle when I tried the number above the character keys but now can with certainty say that it’s a sequence issue.

BTW, the method of selecting the edge THEN toggle copy to copy an edge with numerical input does work in most situations.

All the best

The order is more important with this bug.
Select edge(s), then move tool, Alt for copy and place it somewhere along the wanted direction.(second click)
Then type the wanted distance and hit enter again.
This bug has been reported a few cycles ago…

@colin SU-0020 april 2020

Thanks Mike

Here’s another that is probably related, and definitely occurs if the order is not maintained.

  1. Create a rectangle 24"x24"
  2. Push/Pull to 36"
  3. Select the bottom edge first, then Ctrl copy it up 4"
  4. Push/Pull the 4" face in 3"
  5. Select the top edge of the front face, then Ctrl copy it down to the middle using constraint to Blue
  6. Create an internal array by typing 2/ and it crashes every time if you select before toggling copy

When the video went black is when the bug splat screen came up

If you toggle copy before selecting the edges, it won’t crash.
BTW do this in a new file, I don’t know if it will corrupt or do anything if you try this inside a working file!!! I’ve had this happen during a kitchen model and lost a lot of work :frowning:

It’s directly related to the order which begs the question, if you toggle copy after selecting an edge to copy inward, is it creating issues within the model by corrupting the geometry? I ask because when I export to another software, say 3ds Max, I sometimes get additional faces at the edges that have zero area. I’ve also experienced “random” crashes that may be a result of this.

We do know about this issue. In our system it is known as SKOR-14848.

So far it isn’t fixed, but we’ll figure it out (I’m hoping!).

Awesome to know! Even more awesome to know methods on how to avoid the issue. Thanks Colin!