Copied line disappears when moved specified distance


#1

This issue pops up occasionally. I don’t understand why, and it doesn’t seem to be consistent.

Sometimes when I use the move tool to copy lines and I enter a specific distance for the copied lines, the lines do not appear to copy. This is really basic functionality I use all the time, but sometimes it just doesn’t work successfully.

I’ll point out that it doesn’t seem to be a small or large dimension issue. Sometimes it won’t work to move a line 1", and sometimes moving lines 1/32" works perfectly fine.

This is in SketchUp Pro 2017 (17.2.2555 64-bit). Sure would appreciate any insight.


#2

Can you attach that model so we can check.


#3

Yes. In fact, I started this from a brand new file, and the problem showed up straight away. If I grab the top inner lines, use the move tool, press ctrl for copy, pull down on the blue axis, type in 1/8, and press enter, the lines do not copy down.

line-copy-problem.skp (146.3 KB)


#4

Hmmm, not sure what to tell you as it works for me, which is why I wanted your file in case it was a unit setting, but it seems not.
Works


#5

Interesting! May I ask what version you’re using? I’m going to try exactly the way you did it. I’ll get back with results.


#6

I specifically used exactly the same version.
I have several to choose from.


#7

Well that’s just weird. Even tried on the same corner as you, but nothing. Thanks for giving it a try. Maybe it’s an extension conflict.


#8

Further testing:

Disable all but default extensions: no change.

However, if I select only 2 adjacent lines, it works. Selecting 1, 3, or 4 lines does not work, and selecting 2 lines that do not touch does not work. Also, if I copy the lines upward instead of downward it works.

I’m puzzled at this point. :thinking:


#9

Might be a graphic card issue. Check that your Nvidia is doing the work and that it’s driver is up to date.


#10

I get sort of the same results as you do. Although copying upwards doesn’t work either for me
The remedy is to end placing the four (or whatever number) edges with a final click to arbitrary displacement and only then type 1/8 [Enter]. That seems to work consistently for me in all cases.


#11

Could it be the units snap setting? If it is enabled try turning it off and see what happens.

I find the snap will override the inference point I am trying to use. I generally always keep it off.


#12

I used the uploaded file as is. But [disabling length snapping] didn’t help either, nor did [disabling length snapping plus increasing precision to 1/64"]

It’s just weird that an input isn’t enough for certain edge(s) selections. The second click in necessary (for me at least). Also with decimal + mm + highest precision + disabled length snapping.


#13

Which is why I wanted the model to check that.


#14

I see something happening in the OP gif that looks like shadows of hidden geometry moving around when he’s selecting line and moving the cursor. Look at it closely and see if you notice it. It doesn’t appear on any of the other gifs


#15

@mics_54, the uploaded contains only Layer0, 24 edges and 11 faces. Nothing changes when the “copied” edges just disappear in cases mentioned above.

The model also has 6 materials belonging to an apparently deleted Chris component.
So what you see is probably a rendering “issue” in the gif.


#16

Ah yes, I see what you mean now. That does seem to work. I was actually unaware we could use this order of operations. :blush:


#17

SU is recognizing my GTX 970, and the drivers are up to date. 3D settings in my NVidia control panel are all set to default for SU.


#18

Did all the lines get copied?
There is a bug (37995) which is related to this:


@mchandler


#19

This is precisely the issue. I did some searching before starting this thread, but hadn’t found that bug. Thanks for the info!

Also, I went looking for that bug (37995), and I can’t find anything anywhere. Surely there’s a place to reference specific bug issues?


#20

I am not sure if there is such a place on this forum. It was mentioned in another.