Cannot copy edges when I type a distance... nothing shows up...!

Longtime Sketchup user, just upgraded the entire office to 2021 Pro.

We’re having an issue where edges will not copy, when you type a distance by which to copy them.

For example, I want to copy an edge up 80 inches along a face, so I can push/pull across above that to create the wall above a door. I can copy to a snap location, like the midpoint of the vertical line, then move the line to the correct height by figuring out the distance, but this is obviously not a solution.

I can copy edges random distances, by moving the cursor along an axis and picking a spot. But I need the distance to be precise, and no matter how many times I try, it is simply not working. This seems like an immense bug, has anyone else encountered this? Is there a workaround? I’ve been using SU for 16 years, but I’m at a loss here…

ALSO, another user has the same issue and posted about it in September 2018, with no solution posted!

Thanks, in advance!

Upload your .skp file so we can see what you are working with.

Cabin_CAD.skp (157.1 KB)

What edge are you trying to copy and in which direction?

FWIW, it would be a good idea to turn off Length Snapping and set Display Precision higher so you can see smalldimension errors.
Screenshot - 11_10_2021 , 8_20_37 AM

I’m trying to copy the short horizontal edge at the base of that wall up by 80 inches.

I made the changes to Units in the Model Settings, appreciate the tip, but it doesn’t solve this issue…

This is a known bug since four versions or so. Change the order of operations:

Place them at a random spot, then type the distance and hit enter.


That’s insane, that it hasn’t been addressed in that time, but that someone figured out this backwards workaround… Umm, appreciate you lowering my levels of anxiety, but here’s hoping Trimble pours some of their massive industry-leading endowment into fixing one of the most basic commands in SketchUp.

It works for me to copy the edges up 80 inches. Since @MikeWayzovski says it doesn’t work, I must be doing something wrong.
Start moving the copies to tell SketchUp which direction you want them to go, let go of the mouse and type the distance.

1 Like

Yeah, that’s the way I’ve been doing it for over a decade, it’s just not working for me at the moment, Dave.

Curiously, one of the other doorways over to the left had absolutely no issue copying an edge up a known distance, but it was an outlier. When I tried more of them, I was getting the same error as before… It’s seemingly random, both within the file, and from computer to computer.

What I don’t understand is, if this would NEVER be acceptable for a basic AutoCAD command, why is it acceptable for SketchUp? And by acceptable, I mean that it’s gone unresolved in four releases…

Personally I’ve never seen this “bug” in action in any of the 17 versions of SketchUp I’ve used over the years.

Likewise, I never encountered it in 2020… I was just nervous, because I lead the charge to upgrade everyone in the office to 2021, and the glitch is baffling…

It works as it has always done using this procedure:

1 - Select the required edge or edges.

2 - Select the Move tool.

3 - Press and release the Option key (on Mac) to activate the Copy Mode (a + sign appears beside the cursor). Do not keep the Option key pressed.

4 - Click on any of the selected edges.

5 - Move up along the blue axis.

6 - Let go of the mouse and type 80". Do not click in the Dimension Window before typing the required displacement.

7 - Press Return to validate the input.

Thanks Jean, but that’s precisely how I’m used to doing it for over fifteen years… it’s just not working now. For me or for other people in my office. Except once in a while, when a random edge will actually copy vertically a known distance correctly. For now, I have to use the workaround that MikeWayzovski suggested.

The official bug report stated: "Move Copy doesn’t work properly with edge(s) " so that may explain the different outcomes and making it hard to reproduce. Some of us are more lucky, I guess…

watch the entity info:

bug SU-020

I’m not sure if the 2018 report is the same issue, but this variation was reported in May as well. I logged a bug report about it, and I know the issue is being looked at. Hopefully soon I will see a version that has it fixed.

The easiest work around is to type your distance a second time. So, 80 Enter may do nothing, but 80 Enter again will give you the line you wanted.

1 Like

I see this issue once in a while using SketchUp Pro 2018 - the copied edges do not move the typed-in distance. I’m not sure if they moved just a tiny fraction of an inch, or if they did not move at all. The Undo stack shows that a move/copy (I can’t remember how it is spelled in the Undo function item) was performed. When this happens to me, I Undo the mystery move/copy (because I can’t trust what actually happened), then create a guideline at the intended position, then perform the move/copy using the guideline as target rather than typing in a distance.

I have a vague memory that if I close the editing context of the opened component or group and then re-enter the same editing context, the move/copy-via-typed-distance will work OK. At any rate, it does begin working as expected without having to exit and restart SketchUp.

The next time I encounter this issue, I will try to remember the work-arounds mentioned by @MikeWayzovski and @colin .

Here is my 2017 file that I use to reproduce the steps. Follow the text and see if it then goes wrong in 2018.

Copy Mode Mode Type 2 Enter.skp (529.0 KB)

Yes, I can see the issue in 2018 following the steps listed in the SKP file. The work-around of typing the distance a second time works successfully. Good to know!

Don’t worry, I can take teasing. I happen to be older than many of my colleagues, but I am still hopeful of a fix in my lifetime.