Copy and paste in place does not work!

I am experiencing a very odd problem: copy/paste in place and cut/paste in place do not work! One of the simplest things one can do in Sketchup and it is not working 90% of the time. All I get is the annoying error sound.

I suspect there is a problem with this file as it has been crashing a lot.

My setup: Mac OS High Sierra, Sketchup 19.2.

Any ideas?

How big is the thing you’re trying to copy or cut? I’ve had cases where it didn’t seem to be working but it’s because what I was copying or cutting was huge (loads of geometry) and it was just taking a long time to get it to the clipboard.

When do you hear the sound?

The size does not matter. The problem occurs even when I am copying a door or some other small object.

When performing the paste or paste in place action.

Have you tried copying the relevant parts of your model and pasting them into a fresh model in an attempt to sidestep whatever is causing the problem.
You can copy from Outliner if everything is in groups and components.

Is it normal on Mac to get an error sound if you try to paste something unsupported, e.g. text? On Windows you get no feedback in such cases, like when there is nothing in the clipboard. Also, in the Edit menu, is Paste enabled or grayed out? I’m thinking some other program may put unsupported data in the clipboard.

1 Like

I was thinking about the same. Unsupported data. On windows, you can clear the system’s clipboard and you now have the abilty to check the settings on multiple copy functionality (history clipboard). You can also clear the clipboard.

I used an app for multiple clippings on a Mac, but I can not recall if that ever caused problems in SketchUp. Nor do not know how to clear the contents of the clipboard

you do get a warning on a mac if the receiver can’t handle a paste…

try pasting a gif into SU for example…

both ⌘V [paste] and ⇧⌘V [paste in place] will result in a system sound…

john

There is no built-in command to clear the clipboard on Mac and the native clipboard holds only the most recent item, not a stack or history. There are add-on applications that provide a multi-level history, but I’ll assume @edson is not using any of them as he didn’t mention it.

@edson, does copy/cut - paste work in other apps? Have you tried restarting the system (that clears and restarts the clipboard process).

You can see the current contents of the clipboard via the Finder menu Edit->Show Clipboard. This will open a window that tries to display the current contents. Unfortunately, its ability to present them is pretty limited. What you see depends on the type of the contents. For many kinds of proprietary contents (including cut/copy from SketchUp) the window is blank and says “Clipboard contents: unknown” in its bottom border. So, showing the contents will clear up the situation only if the contents are something that Finder recognizes but SketchUp can’t accept. Worth a try, but not a high likelihood of giving an answer.

1 Like

Thanks for all the suggestions. However, I can assure you that I am trying to copy/paste only normal geometry and not very heavy at that.