Converting a sketchup file and saving as a dwg drawing


#1

I am working a courtyard design for a condo association in the Minneapolis area. Of couse, it is 20 degrees, and snow on the ground, so it makes measuring this site almost impossible. I am still very new to sketchup, but I was able to capture a birdseye view of this site from Google Earth, and I saved it as a jpeg, and imported it into sketchup. I am trying to trace over the existing site, which has a lot of curvlinear lines (sidewalks), and am having difficulty keeping on one plane, and trying to offset the walkways 5 foot. I did resize the Google Sketchup photo, so I know it is too scale. I will keep working on the tracing. I believe the lines have to be cyan in color with curves to indicate that they are on the same plane.

But, here is my question: Is it possible once I get a base map drawn of my existing sidewalks and other amenities on this site, can I export this, and save it as a dwg. I want to work on my Autosketch 10 cad program, which is a toned down version of the full blown autocad programs out there. Thank you.


#2

File>Export>2D Graphic>Export Type=AutoCAD DWG File
I, too, use AutoSketch for all my construction drawings. Glad to see someone else uses Autosketch.


#3

Hi Paul,

This is great that I have found someone else that uses Autosketch. Not to many. So, I appreciate so much you getting back to me. In the attached file, I have traced over an area that is basically a 5 foot wide sidewalk surrounding a grassy area with the shape in the center, being a golf green that we will be taking out, and planning a water feature, pergola, patio, and possible outdoor fireplace. My measurement on the long straight inside line on the far right is 55’-6" long. I am getting the dwg to paste to my desk top on a blank non-scaled template. I than select my area, and paste it onto one of my scaled drawing templates (1" = 10’-0"), but I am not getting a scaled drawing. Let me know in the dialog box that I have attached what settings I should have. I usually open most of my dwgs in autocad 2000 to be on the safe side. Thanks.


#4

OK. I am partially stumped. I never see the dialog box. I, of course, draw in SU at full size. Then I export to DWG. I then go into Autosketch and open the DWG that I just exported. I then copy and paste into an Autosketch drawing that has the scale set to 1/4" and my dimensions from the SU model to the AS plan are correct. Maybe someone else out there can help with the dialog box. Sorry.


#5

When I export to DWG, the only option I get is “AutoCAD DWG File” so I use it. I never had to SU to export as a AC2000.


#6

@pault728, AFTER you select the export filetype, IF that filetype has export options, then the “Options…” button (on the lower right of the dialog box,) will bring up the Options dialog.


#7

Thanks. Dan. Found the Options. Never used it before and I have been exporting DWG for several years. Anyway, the only options that I have activated are: Full Size - Check; Release 14 is selected and Profiles are selected as “none” Everything else is “grayed out” Hope this helps the cause.


#8

When ever I get a dwg from a client, I also have never opened the options tab, but since it was not scaling properly, I decided to see what was there. I will continue playing around with it, and see if I can get it to scale out. So, I exported directly from sketchup to the dwg file. Was I suppose to send it to layout first? Thanks.


#9

I don’t use Layout. I open the DWG file in Autosketch. Then copy and paste into my working AS file. Maybe select the “Full Size” box. I noticed it is not checked on your options dialog box you posted.


#10

You guys know there were scaling export bugs in SketchUp ?

Check the release notes for SU2015. There were fixes for this release.

Release Notes

  • Fixed an issue where DWG/DXF files imported into other applications were scaled incorrectly if SketchUp and the other application were not using inches.

#11

I was not aware of the scaling bug. I lucked out. I export from SU8 and SU13 and never had a problem because the receiving drawing (Autosketch) was always set to inches. I always work in inches so I never noticed. Thanks


#12

I am still on 2014. With all of the bugs I have seen, I am waiting for some of these issues to get resolved. I did hit full size, and it came in way too large, so, I think this is the area I have to play around with. I am not sure how you get yours to go into autosketch at the correct scale Paul, without having to go into the dialog box. I will keep playing around with it, unless there is all a scaling bug in 2014


#13

Note that to get a 2D DWG export to scale, your camera must be set to Parallel projection - perspective images cannot be to scale. It must also be facing the objects that you need to export to scale.

You can also export to DWG via the 3D Model option. This has an advantage that arcs and circles exported become true AutoCad arcs and circles and not line segments like in the 2D export.

Anssi