[HELP] Convert 3D dwg drawings to sketchup

Here are the files:

1- https://goo.gl/skj51m

2 - https://goo.gl/rP6v3s

both are in dwg. If someone manage to export these into sketchup or an .obj file, that would also be great.

Are you hiring someone to do this work?

nope. it was from a colleague. just needed it to convert to sketchup.

Is this for your work?

yeah, but it’s mostly a personal project.

Since it’s a work project, you need to be using SketchUp Pro.

Yeah I have my own personal copy of SketchUp Pro. It’s just that it can’t import the model into sketchup, eventhough I’ve tried using the import function.

What happens when you try? Those are large files and they will take awhile to import.

You should fix your profile.

I have no problem importing the first one (Eagle’s Lair). Took only a couple of minutes on my iMac.

I don’t have access to Google Drive, but will put it up on OneDrive, with a link.
Here’s a link to the file.

It reduces to 17MB as SKP from about 56MB as DWG.

It’s getting extremely late here, so I’ll look at the other tomorrow.

PS. It’s lost a lot in the import - I was able to look at the original in AutoDesk TrueView, and it had colour, much detail in wire eyelets, shackles etc. which seems wholly or partly missing in SU. Unfortunately, I can’t get a screen grab quickly for comparison - TrueView is running under Windows 7 in Parallels, and I can’t see how to capture the image.

I just used the default import options, and didn’t capture the import report to see what might have been ignored as there are quite a number of AutoCad object types that the importer and/or SU can’t handle.


Finally worked out how to take a screenshot from my VM - here’s what the original DWG file looked like in TrueView:

And here’s some of the detail that’s lost:

Importing your second file gives the following Import Results:

And an apparently empty SU file with half a dozen components, none of them showing in the model, and none of them worth having when placed in the model - they look like some sort of AutoCad symbols for lighting.

I think that like the Irishman’s response when asked ‘How do I get to Ballysloughguttery?’ I would say ‘Don’t start from here’.

You might have better results if some other program can convert direct to .obj format.


Thank you so much for the effort! Yes, I think the main problem is because the initial modeler modeled in pure AutoCAD, rendering exporting to Sketchup useless.

I have a workaround for this, but it made viewing in Sketchup super laggy experience. You can barely edit it because you can’t move anything without waiting for 10 minutes for each action.

My workaround: I exported it to Fusion360, convert it into fusion, open the cloud version of Fusion360 in my browser, convert it into Sketchup, and received the exported version via mail.

To me it looks like that the detail lost is very small. It might help to use a bigger import unit (meters or feet, perhaps)
The import statistics hint at something else than pure AutoCad being involved. Something like Mechanical Desktop? SketchUp can only import regular AutoCad 3D geometry.

Have you tried duplicating the CAD file and then purging/deleting anything you do not need including title blocks etc?

I just have a ???

@kennyvoorhees ,

Then you should ask the question in the appropriate thread rather than to make your statement as you just did in this thread. That effort achieved nothing because no one can tell what your issue is, so it is counter productive. The Forum Guidelines encourage users to be mindful of other users’ time. (Click the bold type to be taken directly to the Forum Guidelines.)

Posts framed in a manner such as your example may simply be deleted sometimes by an admin to avoid unnecessary confusion.

In most cases, it is best to start a new topic thread to post your inquiry unless the subject is already being considered in an existing post.

This topic was automatically closed 91 days after the last reply. New replies are no longer allowed.