Constant Crashing...Literally every minute

This is excruciatingly irritating. It’s to the point where I set my auto save interval to 1 minute. Even at 1 minute, it can’t keep up with the crashes. The program will crash on intricate 3d models as well as simple lines. I spend about 5 times as much time opening and closing the program than I do in the program itself.

Extra Info:
This mostly happens when ever I try to use the move tool. I could move a giant model or a line. Complexity makes no difference. This also include rotating.

First things to test to get some idea of what is happening.
Turn off autosave itself, it has been know to clash with things and cause crashes.
Turn Off Hardware acceleration in Window/Preferences/Opengl.
Restart and see if that at least helps.

I believe I tried the hardware acceleration already. Disable didn’t even allow the program to run if I remember correctly. Either way I’ll give them both a shot right now.

I left acceleration enabled and simply disabled autosave. That seems to have been it. Me freaking out about losing my work is what prompted me to reduce the interval period which only made it worse. That kind of sucks though. Autosave actually came in handy sometimes.

That seems to have been the complete problem. Thanks for the help.

I kind of feel dumb for not realizing that the frequency changed when I changed the autosave frequency.

I’m glad it got you working, but there must still be an issue somewhere that is causing the problem with autosave.
It could be a plugin with an observer
Or the graphic driver
If you tell us what plugins you have one may jump out as the culprit.
But if you can get comfortable with regular ctrl s then nothing should be lost.
Autosave is something I automatically turn off, habit from an earlier pc that was so slow that autosave interrupted my work too much and I’ve never gone back to using it.

This picture is from the extensions menu. This is a new computer, so I really haven’t loaded it with unused plugins.

Phlatboyz Pocket tool is also a source of crashes now. I’ll try turning off hardware accel.

Hardware Acceleration disabled results in an instant crash. I have seen this before.

I changed it from “NahimicMSIOSD.dll” to “NahimicMSIOSDrenamed.dll” and suffered another immediate crash. Hardware acceleration has to stay on.

Keep submitting the bugsplatt reports. Trimble is reading them. If you submit your thousand crashes they might send the swat team!

Now, I’ve experienced something like that before, but it has been fixed.

You mention disabling autosave helps. Are you working on a folder where you have no access rights?

What happens if you run sketchup as admin?


So, did disabling Phlatboyz Pocket tool and renaming NahimicMSIOSD.dll resolve the crash?


I am going to spam the heck out of those reports whenever available.

The pocket is a tool that I actively use. I can’t disable it.
Renaming the .dll did nothing.

not if your crashing…

the suggestion is to see if it’s a problem…

if it is then it can be fixed…

if not then maybe it’s another…


Well spamming was not really my intention… and driven has a point.

My bad. I did not give a proper update. The pocket crash was a result of overloading…something. I use 100 segments for my circles. The tool just was not able to process the circle at that size (10mm) with such a large end mill diameter (6.35mm) and segment count (100).

Sorry about that.

Within reason of course. A new scenario would be an example. Otherwise, you are just going annoy the people you are asking to help you.

it seems you have two versions of the phlatboyztools loading, they may have conflicting code…

try turning one off [the oldest] and report back…