Computer Struggling

I believe I have a top end computer specification below. Iam having trouble with a file that is 35,094 KB not reacting smoothly as it should!
Also Layout is taking quite long to go between pages.
I have purged files Changed GL settings turned off some tags but the problem remains.
Any Suggestions?

*X8070811700F Intel Core i7 11700F (Base: 2.50GHz,
Turbo: 4.90GHz / 16MB / LGA1200 / 8
Core / 16 Thread / 65W / Rocket
UNIT 1.00 1.00 10 0.00 %
MZ-V8P1T0BW Samsung 1TB SSD, 980 PRO, M.2
2280 NVMe PCIe Gen4, Read up to
7,000MB/s, Write up to 5,000MB/s,
IOPS R/W up to 1,000/1,000K, 1.5M
Hours MTBF, 600TBW

UNIT 1.00 1.00 10 0.00 %
CMH32GX4M2Z3200CC1o6rsair Vengeance RGB PRO SL 32GB
(2x16GB), PC4-25600 (3200MHz)
DDR4, 16-20-20-38, 1.35v, Dual

UNIT 1.00 1.00 10 0.00 %
GV-N3060GAMING.OGC-ig1a2bGyDte.R GeForce RTX 3060 GAMING
OC 12G R2.0 (Boost: 1837 MHz),
12GB GDDR6 (15000MHz), PCI-E 4.0,
2x DisplayPort 1.4a, 2x HDMI 2.1,
WINDFORCE 3X Cooling, Metal
Backplate, RGB Fusion 2.0, Limited
Hash Rate Version


Nice specs, but more useful would be a link to the file or at least a screenshot of [menu] Window > Model Info > Statistics. (With the checkbox checked for nested components.

A 35 megabyte model can easily be one that brings a 3D modelling application to its knees. I think if I tried I could manage to do it with a very much smaller file.
This one is about 440 Kb and is quite clunky on my computer that is about 15% slower than the one of the OP:
100ionic.skp (439.7 KB)

Thank Mike

I have deleted components from my model e.g., furniture fireplace etc and has reduced the file size down to 23MB from 31.8MB (screen shots of Model Info attached with show nested components tricked ) The file now acts normally.

But what I was trying to find out is if my computer with the specification shown in my first comment should be able to handle the larger file. Do I need to get it looked at?

Your rig is a top level one, fast late generation processor, enough Ram and a high spec video card.
The only thing to look at is to see if SketchUp uses the graphic car [menu] Window > Preferences > OpenGL (sometimes, this is changed via a Windows update)

There might be something in the model (3D Warehouse component!) that causes a lag.
This could be a texture or a high count of edges, even styles can sneak into your model.
The number of edges is not overwhelming, it usually gets tricky when going over 1~2 Million, so it might be/have been a texture.
I check sizes of textures with an extension called ‘Material resizer’ which can also downsample the texture to a smaller pixelsize.

Thanks Mate very helpful
Great feedback

Check in Window menu>Preferences>OpenGL>Graphics card details that SketchUp is using your Nvidia card. If it isn’t. right-click on your desktop, open the Nvidia control panel, and, in its 3D application settings, make sure that SketchUp is set to use your Nvidia graphics card. Depending on version, it is the “OpenGL rendering GPU” setting or right the first available setting. Autromatic selection doesn’t work if your computer also has Intel integrated graphics.

Thanks for assistance much appreciated! Copy of my GL settings attached looks like it is reading the Navida Card.

Depending on the resolution of your monitors, you need not go as high as 8x antialiasing.

Normally you would have Use fast feedback checked, and given that you have a lot of VRAM, checking Use maximum texture size should be ok too.

In your models, see if View/Edge Style/Profiles is checked. Unchecking that will help the performance a lot.

Thanks again for your help
What is preferable for performance in the OpenGL settings high or low (4 or 8)
I am going to get my computer looked at as the same file is working smoothly on my old surface Pro

I see on your screenshot that the Use fast feedback is disabled to change… I guess it is not normal.

Perhaps some other general advice helps:

  • Did the Sketchup worked properly before? Or it is a new installation of Sketchup?
    Try to download the latest installer of SketchUp Pro 2022.
    Make sure SketchUp or Layout are not running.
    Right click on the downloaded installer file Chose Run as administrator and when prompted choose Repair.
  • Did you get a Windows update recently?
    Sometimes it is ruining up the graphic card driver. Go to Nvidia site download and update your graphic card driver to latest one.
  • Are you using Windows 11 Insider (developer) builds? There are many reports in the forum it is causing a problem.
    Roll back to earlier version or use official builds.

Thanks for the feedback. I have run the repair in sketchup start up and updated the graphic card and yes it was happening before the Windows update.
I am now taking the computer to the people who built it for their assessment.
Thanks again for you help

A bit clunky but not that bad on my 2017 Macbook Pro.

I edited the style by removing the profiles and the model orbit, pan and zoom really quickly.

I made the file on purpose, of course. It manages to put over 5 million edges into a 440 KB file.