Components do not display accurately, even though measurements are the same

Sketchup Pro Subscription
Current version of 2024 Desktop on Windows 11 (24.0.484 64-bit)
Sketchup Checkup passed.
Sketchup Experience: Learning.

I am learning the program and cannot figure out why two components do not match up visually, even though the dimensions indicate they should. I recreated the components and got the same result when using them in a new part of my model.

Also, I created the two components at the same time using the same guides and they matched visually at creation. It is only when reusing the created components.

TIA for any help.

Try going into Window → Model Info and changing the Display precision.

You may have it set too high to display your smaller units.

1 Like

Share the .skp file so we can see exactly what you’ve set up. Looks to me as if you have Display Precision set too coarsely for what you are modeling and you probably have Length Snapping enabled.

1 Like


Horowitz, Bar Cabinets V2.skp (125.6 KB)

This is work in progress.

So exactly what we both indicated. Set the Display Precision to something more suitable. I would set it to 1/64" even though I wouldn’t work to that in the shop. And turn off Length Snapping.

Thank you. I will give that a try.

Fix it by opening the side component for editing and using Push/Pull on the walls of the grooves to move the groove to match the back panel.


A couple other things to point out.

  1. The Tilde " ~ " next to the Tape Measure Tool shows when measures are approximate. So that’s one indicator to be aware of.

  2. Profiles in Styles → Edit can be turned off. This will turn your style into a ‘fast style’ as indicated by the tiny icon in the bottom right corner of the style icon. The line (edges really) are then smaller. For some these smaller lines make it easier to see when edges are on surfaces, etc.

  3. Save a template using Save as template with Length snapping and profiles off as well as the display precision you want.