Lengths don't add up

Frequently, when I assemble shapes together, the resulting dimensions don’t add up.
Like the screenshot below.

Both rectangles are 1’3" long, but when next to each other, the total length is 1/16" longer than it should. I have zoomed in to the joint and it doesn’t show any gap.

What I am doing wrong?

You are looking at rounded dimensions. Go to Model info (second from bottom on the right) and turn up the precision of displayed units. Sounds like it’s set to 1/16 which I believe is default. While you are there turn off length snapping. Are you typing in the size of those objects when you make them or dragging them out by hand?

2 Likes

I usually type it in, but once in a while I drag.
And sure enough, that was it. The rectangles were actually 1’ 3 1/64".
Thanks!

2 Likes

And yet they don’t show the preceding ~ (tilde) that SU uses to show that dimensions are approximate.

Thanks to Steve (@slbaumgartner) for pointing out in a recent post that if dimensions are in feet, inches and optionally, fractions, the ‘approximate’ tilde is not shown.

Bug? Odd design decision? Who knows. I certainly didn’t, before Steve pointed it out.

If you changed your units to Fractional (just inches and fractions, no feet) do you see the ~ showing on at least one of your dimensions?

I do see the ~ (tilde) on other dimensions sometimes, but not in this case. I don’t know the logic that determines when it is shown or not.
Switching to inches and fractions did not make the tilde appear.

Seems like the mystery is not quite solved. Even with the precision set to 1/64" some measurements don’t add up.

In this case, the distance between two points is 3’5" but if I pick a point between them and measure the distance on either side, I lose 1/64" somewhere.

It’s not the end of the world or anything, but aren’t computers supposed to be good at math? :slight_smile:

Post the model shown in the last reply so we can check it to see what is happening. As an exercise I used your 3’5" dim and placed an arbitrary point to dimension to. No matter how I measured the numbers added up.

Here it is.

Length Bug.skp (1.3 MB)

All three dimensioned distances are not exactly to 1/16" and are being clandestinely rounded.

I switched the units to “decimal inches” and now I see my measurements are off by small fractions.
My 3’5" is actually 40.996277".

Now, two questions:

  1. Should there be tildes in front of those numbers?
  2. Assuming I got this length by dragging; and I do have length snapping on. Shouldn’t the length have snapped to the nearest 1/64" fraction?

While I was typing those questions, I noticed something else looking odd…
My “snap interval” is set to 0.062520". Is that normal? That’s a tiny bit more than 1/16". Shouldn’t it be 0.0625" ?

Did I accidently change that snap interval?

It is best to stop worrying about the snap interval and turn off Length Snapping altogether. As a feature it is completely useless.

2 Likes