Can't align components perfectly


#1

I’m using a 1/16" reference grid for all of my sketch, but my objects don’t seem to align to the same reference grids. Visual gaps between components are clearly visible, despite being reported as having 0" width using the measuring tool (image attached).

image

I’ve also created an arbitrary neighbouring measurement, just to indicate scale. Is there a different way to make objects “touch” other than by using the move tool?

All my relative angles are square (0, 90, 180, 270), so it’s not angular roundoff errors. I’ve also tried moving both the objects independently, in the hope that they would “re-snap” to a common reference grid, but it doesn’t change anything.

Not too sure what to make of it. Is this intended?


#2

Could you share the SKP file? Your screen shot doesn’t help much.

It looks like you have your precision set more coarsely than you are trying to work.


#3

Dave is right, the model would help.
But my guess would be you have the precision set too course in model info, this allow it to show you 0" when it is probably1/16" or 1/32" or something smaller than your settings allow.
Secondly how are you moving your components?
Click somewhere and drag or grab the corner and move?


#4

thanks.

Attached my skp file. Hopefully it opens in the view I was in when I saved. It should be zoomed in on new component “Foo” next to a table leg – that component cannot be aligned to the leg solely by moving.

@Box, re: guess. That was my initial intuition too, i.e. that somehow the two components have been designed on a separate snap-grid. But I’ve been on 1/16" all along the design. Although that’s increasingly difficult to prove, given the amounting photo and sketch-file evidence that this gap is measurable to non-nil.

@Box, re: 2nd concern, how I “move”: I use the select tool (‘space’), click the component (usually in the middle of a visible face), make sure that all the faces, edges, and vertices of the component are selected at once (as opposed to a single edge, or face), use the move tool (‘m’) , and drag the selection along one of the axes. I often type in the amount I want once the direction is set + ‘enter’.

Update: I thought at first that changing the precision from 1/16" to 1/64" in the “Display” menu didn’t do anything, but it turns out that displayed measurements on screen are only refreshed if the mouse cursor passes over the main panel. So, it turns out that, my screenshot’s 0" turns into 1/64" if I bump up the “Display->Model Info->Precision” to 1/64". => The distance between the components is indeed > 0".

However, it remains that I can’t suppress the 1/64th gap solely by moving the components. My objects’ movement appears to be stuck in 1/16" quanta, regardless of the model Info’s precision setting.

I’m new to this program, needless to say. But I would have expected sub-granularity distances to display as ~0" instead of 0", like it does in so many other places.

alignment_offset.skp (641.0 KB)


#5

That’s why I asked how you were moving things.
Click and release on an appropriate point, in this case the corner, and the component becomes attached to the cursor, then move to where you want it and click and release to place it.
Move


#6

aah! fantastic. My question was on Sketchup Free (online), but your illustrated steps (which appear to have been made on a desktop version) work online too.

The important bit (and I think this is what I missed) is to initiate the movement from a corner, or an edge. From a face it won’t snap to the other component’s corner/edge. The displayed tooltip victoriously updates with “Endpoint on {Component Name}” (for corners), or “On Edge in {Component Name}” (for edges).

You mention click+release. I’m used to ‘dragging’ when moving objects. It could be muscle memory from my desktop environment. But I thought I should mention either of “Click+move+Click” (click and release, as you call it) or “ButtonDown+move/drag+ButtonUp” work equally well for snapping to another component.

I still don’t know how I managed to make the first non-1/16"-aligned object, but at least now I can correct the issue.

Thank you!


#7

Yes, if you are just moving a short distance, but click and release attaches the object to the cursor so you can orbit, zoom and pan though your model to place your object somewhere that was initially well out of view.


#8

This topic was automatically closed 91 days after the last reply. New replies are no longer allowed.