Components, dimensions, gone missing

This is specific to Sketchup 2017, at least that’s what I’m using. I’ve been away from Sketchup for several months (don’t ask), but when I got time to get back to things I’m not having a lot of fun.

When I open a file, the components and dimension info is missing. The components window show none! I’ve even gone so far as to open the completed file from DaveRs book. Same thing!

This all tells me I’ve toggled something. But what? I’m at a loss.

Help!! Please?

Best Regards

Jeffrey Beardsley

Oh, and I’m using Version 17.2.2555 64bit

Do you see the red, green, blue, model axis or is the model window just blank?

A recent windows update may have affected your Intel graphics drivers.

Sounds like an Intel graphics update from Windows broke the OpenGL support. Go to Window>Preferences>OpenGL. Untick Use Fast Feedback.

Oh, I see the axis. I even see the model and can manipulate it. I just can’t see (or find) any component or dimension information.

Do you mean the tray isn’t being displayed? If that’s it, go to Window and check to see that Default Tray is enabled.

How about a screen shot of what you are seeing?

One screenshot coming up.
Yes Dave, I’m back to my cabinet. It’s a learning process. sigh.

I’m still not seeing what you’re missing. Are you referring to Entity Info? That panel is, by default at the top of the Default Tray. Looks like you need to scroll up in the tray to see it.

If you are referring to the blank Components panel, click on the house icon to the left of “My Models” to see the components in this model. FWIW, it appears that the folder called My Models is empty. Is that correct?

Trust me, you are seeing exactly what I’m seeing! The Entity Info box is empty. and there is nothing in the My Models window either.

As I stated earlier, I even went so far as to open your eBook and open the completed model in that. Nothing!

Entity Info will not show any entity info unless you select an entity.

My Models is not In Model which is what you get when you click on the house icon.

Did you look at your My Models folder to see if it is empty? Is it possible it was moved to a different location on your computer?

I can’t fathom how I would have moved the My Models folder. I wonder if my install of Sketchup has become corrupted somehow.

The installation shouldn’t have changed.

Let’s deal with Entity Info first. Scroll up to so you can see that panel and select something in the model. Does Entity Info display anything?

Next, set the Components panel to display In Model (house icon). Does it display the components in your model?

Yes, when I selected the top drawer, Entity Info showed “Layer 0” and “Top Drawer”.


One thing I have discovered. The “Outliner” shows my components. If I select a component (triple click) it is highlighted in the Outliner. Nothing shows in Entity Info. Nothing shows in Components.If I run a tape measure over a component, it returns accurate info.
I can’t change anything. All selections that would allow me to resize or alter, are greyed out.
I also can’t recreate that component as a new component.

Is it possible I’ve deleted a metadata file of some sort at some time?
Would it be possible to recreate it.

How about sharing the file? Or maybe you need to let me look at your screen with you.

OK, here it is.
3 Dwr Base cabinet 3DB36.skp (475.6 KB)

That would be excellent Dave. Would you have some time in a couple of hours? I’m just headed out the door to church.

Here’s what I see. I set the Components panel to display In Model and it shows the components in the model. With the case side selected, Entity Info shows that.

I might have time in a couple of hours. It depends on exactly when.