Component Spray Tool Plugin Not Working - Unsigned

Hi all,

I downloaded the Component Spry Tool plugin for sketchup from here: http://www.crai.archi.fr/rld/plugin_details.php?id=76

It was downloaded as a zip, so I renamed the file extension of the zip to .rbz.
I then used the extension manager to install the plugin by choosing the .rbz file that I made from the zip.

The manual for this plugin says that the plugin will be accessible from the draw menu in Sketchup, but it is not there. In the extension manager it says that it is “unsigned”:

Does anyone know what is going on here and maybe how to fix this and make this plugin work? Am I skipping a step?

Thanks in advance.

That extension predates the extension signing system, but unsigned will have no effect unless you have set the extension manager “Loading policy” to higher than the default “unrestricted”.

Did you restart SketchUp after installing the plugin? That is probably necessary because it is a traditional plugin, not really an extension. It should add a submenu item to the Draw menu and should create a Toolbar.

That extension is almost six years old… Nut sure if it is compatable with the newer version of SketchUp, or not.

Thanks for the replies. The Loading Policy is set to unrestricted. When I restart sketchup after the installation of this plugin, I get this error:

Error: #<SyntaxError: c:/users/caleb/appdata/roaming/sketchup/sketchup 2017/sketchup/plugins/compospray/compoutils.rbs:511: Invalid break
c:/users/caleb/appdata/roaming/sketchup/sketchup 2017/sketchup/plugins/compospray/compoutils.rbs:520: Invalid break>
c:/users/caleb/appdata/roaming/sketchup/sketchup 2017/sketchup/plugins/compospray/compoutils.rbs
Error Loading File compoSprayToolbar.rb
Error: #<NoMethodError: undefined method compSpray_env' for main:Object> C:/Users/Caleb/AppData/Roaming/SketchUp/SketchUp 2017/SketchUp/Plugins/compoSprayToolbar.rb:7:in<top (required)>’

Any ideas as to what this is about and how to fix it?

Thanks.

try the later version at SketchUcation plugin store…

even it may be too old…

CompoSpray link

john

You are loading a VERY VERY old version.
It was updated [for v2015 compatibility] some years ago [by me for Didier].
https://sketchucation.com/pluginstore?pln=compoSpray
I’ve just tried it in v2018 and it does work…
Because it is so old it is unsigned, ensure your Extension Loading Policy is set to ‘Unrestricted’.

Please remember it is old and clunky !
With inappropriate settings, which might produce hundreds of instances, it can take ages to run !!

Thanks, I downloaded that newer version and it works now.

Thanks everyone for your time.

This topic was automatically closed 91 days after the last reply. New replies are no longer allowed.