Component not in a binding box


#1

Hi there

I am trying to make a pillar that I can repeat around my building. I have created a tall rectangle, selected it all and created a component out of it. It appears in the components list but when I click on it it acts like a normal piece of drawing and to edit it I do not have to click into the binding box like I normally do. Is this right?

Amy


#2

No. It is isn’t right. Is the rectangle you selected attached to some other geometry that you didn’t select when you made the component? If so, you likely missed ticking the box for Replace selected with component. Can you share the SKP file with us? It would be easier to identify the problem.


#3

Thanks for your help. This is a fresh install of Sketchup on a new computer so I haven’t created a component with it yet. I tried it four times without luck until I read your message. The piece was completely on it’s own so I know everything was selected and the box replace selected component was ticked but I toggled it off and on again and for some reason it worked then. The box is back!


#4

Strange but if it works…