Complex model out of square. Please help


#1

So i have been working on a somewhat complex building model. Somewhere a few days ago an exterior wall got “tweaked” with the move tool and put a slight twist in it. It was so slight i never noticed it till i went back to that wall and started trying to put windows in it. Since it isn’t square the inside and outside walls aren’t aligned so push/pull won’t work, etc. Unfortunately i have spent hours working on other parts of the model and I really don’t want to start over. Is there any process or tool to make the walls square again?


Face Not Created
#2

It would help to see the SU file to advise on how much work is needed to put things right. Much depends on how much has been made into groups or components. In many cases, it is easier to erase the offending parts and redraw them.


#3

There is no magic button that will automatically fix wonky geometry.

The level of difficulty in fixing noncoplanar geometry depends upon the extent of the damage and whether the model is well organized into Groups and Components. Albeit, such errors tend to propagate outside of groups via copying and /or inferring to the existing bad geometry.

• View the model in Monochrome

• Turn on Hidden Geometry

• Turn off Profiles and all the other Edge rendering eye candy.

• Set the model Length Units to Decimal (inches or mm)

• Set the model Length Units-Precision to the maximum, six decimal places.

• Turn off Length Snapping.

• Confirm the Drawing Axes are in default position.

• Install the Query Tool plugin. https://extensions.sketchup.com/en/content/utilities-tools

• Always keep Entity Info open as you work with the model.


• Move the offending endpoints with the Move tool using Inference Locking to constrain direction.

See this section of the SketchUp Sage…


#4

@wp2018

Sharing the model will definitely help us help you.
3MB file size limit here in the forum.
Larger files, up to 50MB, can be shared via the 3D Warehouse.
Use a file sharing service such as Google Drive or Dropbox for files >50MB
Simply post the link in your reply to this thread.


#5

Thanks so much for the input. The link at the end take you to the model. The original model was the main shop with the tools, etc in it. including a 30’ wing. I’m working on an expansion, and am extending the wing by about 30-40’, plus the new “empty” building, It is the long exterior “back” wall that is giving me issues. I’m suspecting that it has something to do with how i joined the addition to the existing model.

https://1drv.ms/u/s!AhMPSp8pzPFmhOcTnZeuhrd7P3A6Mw


#6

The problem starts at the interior partition shown below. The back wall changes thickness there and then increases back toward the far corner, making the wall faces non-parallel.

Edit: as a side issue, you are not using SketchUp’s layers appropriately. You have associated a lot of edges and faces with other than Layer0. That is a road to error, as SketchUp’s layers do not prevent edges and faces from interacting with each other, even if the layer is not visible! Draw and leave all edges and faces on Layer0. Use other layers only for groups and components.

6063 primitives found off layer zero
{“Building”=>1357, “Roof”=>644, “Equipment and furniture”=>383, “Plot plan”=>107, “W and D Labels”=>7, “Layer1”=>71, “FormFonts”=>2617, “Grass”=>733, “Office Walls”=>144}


#7

I have never really understand this, precision comes with correct use of the inference system, or entering it manually, not?
I alway get alerted when a ~ tilde appears in the VCB or Entity info, then I know 'something’s wrong, with the precision set to that level, you create a false sense of precision?


#8

You are basically correct. All that setting a higher precision does is to let you see more exactly how an errant coordinate is different than what you intended. For example, perhaps “~35/64” => 0.55 instead of 0.546875. But setting a higher precision does not cause you to draw more precisely. For that you need to use the inference system and/or the measurements input box (aka VCB) appropriately.


#9

One cannot find errors with the Query tool when precision is set to units larger than the errors.
@Wo3Dan aka @g.h.hubers has mentioned his favorite setting for finding noncoplanar and off-axis geometry.
0.000000mm


#10

@wp2018
As @slbaumgartner says, the improper use of Layers issue looms large over the future of the model.

Placing raw (ungrouped) geometry on a layer other than the Default Layer 0 often leads to odd behavior and unintentional alteration that is not immediately visible.
• Layers in SketchUp only control visibility.
• Groups and Components isolate and protect geometry.

To avoid the problem:
• Always do your work on the default layer, which is Layer 0 • Always make geometry a Group or Component before you assign it to a layer other than Layer 0.


This process will assign geometry back to the Default Layer0.

• Open the Layers Manager and delete all extra layers until everything is back on Layer 0.
• As you delete each layer, you’ll see a pop up window. Select: Move contents to Default layer

See these video tutorial from the SketchUp Folks.

Layers


Components


#11

I’d also add to this list “color by axis” in styles. Especially in wire-frame mode you can more easily identify which lines are off ( assuming the bulk of your model exists in the x,y,z planes)


#12

Thanks for this input. I’m self taught here and its my first model…so i definatley appreciate the help. I drew everything in layer 0, then reassigned parts of the model to be other layers. sounds like i should window over the model, set everything to layer 0, then group things (like the roof) as a separate component?

I’m not certain, but i think its something besides just the wall thickness being off. if you look at the windows on the back wall…they are all a little “skewed”


#13

For a first model, it’s a pretty good attempt!

As others have said, it is a bit messy in its organisation. Correct use of layers and components is key. In general, Layer 0 would only contain groups and components although all raw geometry within them would all be on Layer 0.

All your scenes appear to have a section plane active. You probably didn’t intend that.

The file is enormous. I have a reasonably fast Mac but viewing your drawing with the default layers on was very creaky. It speeded up a lot when I turned inessentials off and did a purge. If this affects you, you may want to set up a scene dedicated to editing where most layers are off and the style is simple.

Some of the window elements are oddly grouped and yes, some are off axis (see below). Once grouped, that’s quite easy to correct by selecting and rotating. If something is only very slightly off axis, it can help to move it way off axis before rotating back to axis just to make it easier to lock onto the right edge.

Tidying up a complex drawing like this is tedious but you will be very pleased you have done it if you need to go on working on it. Also, it’s part of the steep learning curve that means you probably won’t make the same mistakes next time.