Colors in model missing in library

Hello the colors in model are missing in library, i allready did a complete reinstal… but nope, nothing!
Who knows about it

There is an issue in French where the Colors palette is showing two entries for Colors in Model. One is in English and one in French. Selecting the French one, or clicking the house icon, should show the materials in that model. Manually selecting the English Colors in Model, will show as blank.

What language are you using?

Thank’s Colin
i’m using french.
I reinstalled “completly” SU and as you can see in the cap it’s empty.
I can’t the english or french as you said.

Can you try using English, and see if the materials do then show up? In Ventura you would look for the language settings, add SketchUp (you can drag and drop the application to get it into the list), then choose English from the language menu. Here’s a screenshot of my setup:

At that moment I had SketchUp 2023 set to English, and 2021 set to French.

I’m not suggesting you have to work in English from now on! But, if you see the materials it would help to prove whether you have the issue that I’m thinking of.

Hello Colin,
i tried what you said, and
Thank you so !
have a nice day

There was another topic about this, where I gave more instructions:

The fix that came out in the 2023.0.1 update should prevent the double entry and empty in model issue from happening. But, you may need to do this extra steps after the update:

In Finder, Go menu, Go to Folder… paste in this path:


In that folder, delete any .clr files. You’re likely to recognize some of the names!

Reopen SketchUp and see if your language is the only in model entry, and that it has materials in it.

Hello Colin, i did, it work perfectly even in french! MANY THANK’S

Hi Colin
Thanks for your advice.
One of my end users does not have access to delete files, yet he is in administrator mode.
An idea ?


wait, does he have access to the colors folder BUT can’t delete them, or not even to the folder itself ?

If your user has access but can’t delete and he is indeed an admin, he can check the rights on the folder / on the files (right click / show informations — clic droit/lire les informations) and at the bottom, he can check if he has actual writing / reading rights

Capture d’écran 2023-04-03 à 11.51.58

If he doesn’t, he chan change that, since he is an admin. then it should work. I’ve had the case a few years ago where I only had reading rights on some files even though I was an admin. I just changed it and it worked.

If he doesn’t see the colour folder, he may be in the wrong place. There are two library folders :

  • one is at the root of the hard drive. we don’t want that one, it doesn’t contain a colors folder.
  • the one we need, inside the user’s folder.
    To reach it, he need to go to the desktop, go to menu “go” (menu “aller”) and in this menu, if he presses the “option” key he’ll see the library appear.
    Or, in the same “go” / "aller menu, he can choose the “aller au dossier” / “go to folder” option and use the path provided by colin.