SU 2023 - MAC - no more colors in model


Hmm. Tricky.

Ok, since SU23 was released, I’ve been using it on my PC. I opened it on the mac once or twice, to install everything and check a few files. no work.

This evening, I just wanted to change a quick colour on a fil, and surprise :
The “colour in model” section is blank. Not even the default colour, nothing.
And I’m talking on EVERY file. An old file filled with materials, a new one with just the silhouette. My default file, but also SU’s default files.
Moreover, Clicking on the small black house DOESN’T take me to the colour in model. I have to manually pick it in the menu next to it. and i’s empty

List of things I’ve considered :

  • I’ve checked SU22, it’s all fine. The same files have colours in model, while nothing in SU23
  • disabled all plugins, then emptied the plugin folder, nothing
  • full uninstall (both application folder and library preferences) then reinstall. nothing.
  • I gave SU23 full access to the hard drive, so it’s not an issue of permissions (and yeah, I’m admin).
  • Tried running with rosetta. it went really slower, but still, no avail.
  • yes, I’m up to date. yes, I restarted.
  • same goes for the extensions, it’s all up to date. anyway, it bugged even on a clean install.

Finally, I installed a material browser plugin, and loh and behold, my materials are there. But not in the official colour panel. If I select a material in the plugin, it appears at the bottom of the “official” material panel (bottom left), and I can use it. but nothing will appear in the white void.

First image is a 2022 file, with colours.

Then a 2023 file, blank colours in model, and the small house icon not working.

Yet, what the plugin (material browser) sees.

The plot thickens :
If I create a new material (dropdown menu at the bottom), It’ll work. I can pick a photo, here, bricks, and it’ll suddenly appear in the “colour in model” area. Still, non of the others.
However, if I quit sketchup (without saving, then re-open a brand new virgin file (different template even), The material still appears, without texture (colour only), despite not actually existing in this file.

First image, when I create a new material (bricks) in my template.
Second image, when I quit, restart, then open a completely different template.


To me, it smells of temp folder issue, as if the colour panel couldn’t find / access the temp colour folder of the currently open file.

I really can’t say when it started, sometimes between the release and now. Can’t start a bugsplat because it didn’t crash, I’m thinking @colin might know who in the SU dev team might have an idea.

Right now I’m tired, lost my evening to it, and I’ll just put it aside. Hope someone has a glorious idea.

Ok, I’m going to double post, It’s bad, BUT I found something.

I started wondering if it could be a translation issue. so I looked at a way to force SU to run in english and not in french.

I found this

And I tried. and it worked.

This is a temporary solution. Sure, I could work in english for the time being, but I teach sketchup. And many people I teach it to don’t speak english. I’m being paid to teach SU in french. And right now I can’t tell if it’s affecting other people or just me.

So in the end, there is something wrong with the french localisation of SU for mac. (again. what do SU’s dev have against us…? we’re nice people, mostly)
Could it be because of the accentuation ? “Colors In Model” - “Couleurs dans le modèle” or some other variable ?

off course, as soon as I revert to french, it’s broken again. So I’ll stick to english for the next few days, and cross my fingers I don’t have anyone on mac next week.

edit :

If you look closely at the first message, the screenshot of the 2022 version that is not broken, you’ll notice that it says “Colors In Model”. in english. despite being in french SU.

So, to sumup, in 22, english name, works.
in 23, french name, doesn’t work.
In 23, if I force english, works.

Pretty sure sur culprit - and fix are here. translation went wrong somewhere.

I have made a bug report for this already (SU-53455 in our system). I added a link to your post so that when there is progress I can come back and let you know.

Curiously, I don’t get the empty materials symptom. For me, Couleurs dans le modèle behaves normally. I see the initial materials, and any new ones that I make. The Colors in Model section stays empty.

I think that when the duplicate section is removed it will fix the empty materials problem as well.


I also use version 2023 in French and I have no problem so far.

I switched to English using the trick you describe using system preferences and I still have no problem.

J’utilise également la version 2023 en Français et je n’ai aucun problème.

J’ai changé pour l’Anglais en utilisant le truc que vous décrivez en utilisant les préférences système et je n’ai toujours aucun problème.

1 Like

Good to know.
After posting, I thought “hey, you’re still on Monterrey, maybe SU23 is better on Ventura”, and did the update during the night.
No ball. But now you’re telling me it’s an actual bug.

Huh. So it means SU makes a second folder then.
Silly SU. It’s weird that the bug is inverse for you, ok in french, empty in english.

Bug aside, this is a very good trick to know, for all mac users. it makes it way easier to follow tutorials or report bugs, since you get all the names in english, and if you have a translation related bug, it will most likely get it out of the way !

lucky me, no macs for the next 2 weeks. no risk of someone having the same bug in the middle of the course.

edit : gee, if only we finally had a proper colour picker, like on PC? or like on Layout (pc & mac), instead of relying on apple’s tool :slight_smile:

Are you still running Monterey, or are you on Ventura now?

I am on Monterey.

I plan to update to Ventura soon.

I realized that you had said you see no problems. That means you don’t see a duplicate entry in the menu list?

If you don’t, this is looking like a Ventura specific issue. I’m not sure why I see materials in the Couleurs dans le modèle entry, and actual French users don’t. My guess is it’s because in our tests only SketchUp is running in French, the rest of the system is running in English. I may try setting the system to French as well, and then see if both entries are blank.

SketchUp was running in French and my system (Monterey) is running in French too.

Now, SU is now running in English while my system (Monterey) is still running in French.

I did do a test where I ran macOS in French. For me, the Couleurs dans le modèle duplicate entry still shows materials ok.

might be french ventura indeed.

What I have right now (running it in english) is both ENG and FR materials, but only the ENG works.

Capture d’écran 2023-03-07 à 20.11.08

when I run it in french, I only have the FR material and it doesn’t work. as if By running it in french it created a not-so-temp FR folder and it now refuses to be overwritten (since it appears as a standard material folder, not the temp one)

This FR folder does not appear in the application support files (so, user created) nor in the SU app package (SU created, like standard materials). Where did mac os create it then ? because in my case it’s still here, I managed to create a brick texture that became a simple pinkish colour after restart (see first post)
And if SU / macOS created the french folder in a wrong place, might be it.

just in case, my chronology, I installed SU23 on monterrey (last one), left for 10 days, on my return, immediately updated to ventura (last one too), THEN noticed the problem.
I’m pretty sure I played around with 23 after install, either the bug wasn’t there or I didn’t notice it.

I’m also wondering… In SU22, french version, the “Colors in model” choice was in english (again, see screenshot in my first message).
I always thought it was a translation oversight, wouldn’t be a first. But what if it was also a fix ? by forcing (not a dev) SU french to use a temp file in english, it solved the problem (again, not a dev)? and this year, the temp file is in french, and it breaks.

We did figure out the underlying issue, and it wasn’t a Ventura one. Coincidentally, Monterey users who added comments had not done the exact combination of actions that were needed to show the problem, but Ventura posters had.

I can’t give a date for the next update, but it should include the fix for this problem.

The fix that will come out in an update should prevent the double entry and empty in model issue from happening. But, for now you can do something to solve the problem after it has happened.

In Finder, Go menu, Go to Folder… paste in this path:


In that folder, delete any .clr files. You’re likely to recognize some of the names!

Reopen SketchUp and see if your language is the only in model entry, and that it has materials in it.


Yep works,

Something I’ve been wanting to tell you all for a while…

The underlying problem was a more serious one, and we were lucky really that non-English language users saw such a visible symptom. When we looked into the duplicate entries in the Colors palette we also noticed some other errors, that pointed to the real problem. We fixed that, and as a bonus it fixed the duplicate/blank entries problem.

A fixed version is now live:

Here are entries from the release notes, that cover the fixes:

  • (Mac) Fixed a Colors palette issue where Colors In Model and the native language version both appeared in the dropdown menu. One or both entries would have no materials.
  • (Mac) Fixed an issue where duplicating an existing materials list, or creating a new materials list, would not create the folder in Finder.
  • (Mac) Fixed an issue where adding materials to a newly created materials list would not work.

Here’s the full release notes:


quick update on this thread, so it contains the problem and all of the solution,

Thanks again Colin.

Hi Colin, I can’t find the ~/Library/Colors/ file in folders. I fear that they were all accidentally deleted. Could you instruct me on how I can re-install them please?
Currently I’m having the issue with no colours showing up in ‘paint bucket/colors in model’

Actually I just reinstalled sketchup 2023 and now everything is fine.
Have a great day.

This topic was automatically closed after 186 days. New replies are no longer allowed.