Colors from Material Tray don't match


#1

I noticed colors weren’t matching when applied from material tray. These are samples from Colors-Named. Model on the left and palette on the right. Is there a setting or view that should be changed to see the colors identically?

Using Woodworking Style from the Style Tray and Shaded with Textures on the toolbar, no shadows.


It’s just a colored rectangle laying flat, rotated upright by orbiting with the material tray pulled right up next to it…

I didn’t check any of the other materials.


#2

I think what you’re seeing is due to the shading used to give the impression of three dimensions on the 2D screen. Try this: In the Shadows window, turn on Use sun for shading and set the Light and Dark sliders as shown below.

Compare:



#3

I tried again with those setting and even tried a different template with a different background color. I tried a lot of different colors. Some of them matched exactly and some did not. It’s not that big of a deal since they can be adjusted. I just wasn’t sure if they should be that way. Since some of them DID match exactly, it would seem something is wrong somewhere though.


#4

The template won’t really make a difference although the background color can give the appearance that the color is different. It could be that your monitor needs a bit of tuning. Or maybe the graphics card needs a bit of adjustment. Do you notice the difference more with colors from a certain part of the spectrum?


#5

I will keep an eye on it and note when I run across one. It looks as though it’s not a universal problem. Thanks, again.


#6

Maybe it is but nobody else notices. Most users don’t seem to know about crossing the light and dark sliders to remove the shading so they always see the model with shading applied by OpenGL.

Come to think of it, theGPU driver might have something to do with this. You could play with the settings in the nVidia control panel and see if you get any improvement.


#7

This is Universal. I am not sure if it is a problem.


My appologies, @DaveR already had explained the reason.
In my experience though, if you are looking at the model from top, the colors would generally be lighter.


#8

The greater the angle you are looking at a plane - the more visible the shading becomes. So at at 45 degree angle you would see the right color. When using “use sun for shading” to disable viewport shading you must set the value to 0 for light and 80 for dark. You can use the Match color on screen tool from the material edit windows and test the RGB value for any material - if the value stays the same, then everything works OK. This would be very important when making wall Layouts or creating any graphic design work in SketchUp and LayOut.

Here is an image I made some five years ago:


#9

A simple way of looking at it, the swatch is what you order at the paint shop, he mixes the colour so it is absolutely correct to the swatch. However, when painted on your wall the light falls differently depending on the situation and your wife will always say you got the wrong paint, unless she got it and then she will point out you have no sense of style. Personally I prefer the mahogany.


#10

This is so true. I’ve had to put the swatch right up to the painted wall to convince myself it was the same color.


#11

Convincing yourself, easy.
Convincing your client, possible.

As @box said, Convincing your wife, … :scream:


#12

you got your wife from the same place I got mine. Amazing. G


#13

I’m having the same problem but everything that has been suggested isn’t working for me.

See attached. The selected face should be the same color as the default background, yet it appears to be much lighter. I’ve tried the :use sun for shading" trick that DaveR suggested. I tried rotating the view 45 degrees from Front View/Parallel Projection to see if the color did in deed change, and I even used the “match color on screen” tool to be sure I had a match. Nothing seems to be working. I’m not necessarily married to that particular color; it just perplexes me that I can’t get a visual match.

(Note that I haven’t touched my graphics card settings, as at my work that requires admin privileges and that’s just more bureaucratic effort than is worth going through).Sketchup_Colors%20not%20matching


#14

What have you tried?

Did you adjust the sliders so the Light slider is to the left and the Dark is to the right?

The shadow settings don’t affect the ground color. Those settings only affect shading on faces. If you are trying to match that, you would do better to draw a large rectangle and paint it with the same color used on the other faces.