Color by layer and nicer transparency bugs

Hey all, I have scenes in SketchUp set up to color faces by layer and the edges “by material” so they also reflect the layer color. The scenes look correct in sketchup, but when I select the same scene in layout it consistently colors a handful of edges throughout the model black. There isn’t anything weird about those edges, they are not on a different layer nor do I even have a layer that is black that would be instructing it to be that color – again, the same edges look correct in SketchUp. Any ideas how to fix this?

Also, I have transparency set to nicer in a couple of styles – again the scenes look great in SketchUp but they revert back to the faster transparency look in Layout. Is that a current limitation?

I am in SketchUp/Layout 2019 (not .2)

Can you share an example LO file that shows this?

Which version of 2019 if not .2? .0, .1, or .3?

Your profile still indicates 2017. Perhaps you could update that.

Thanks for the quick response, Dave – didn’t realize I had that information in my profile, I’ll update. I am in 2019.0.

Unfortunately I cannot share the model as it is a confidential project but I am attaching a couple of images that show the layer color issue. I have attached one from SketchUp which shows it correctly and then the layout which is incorrect. It is worth noting that the issue comes up only when I set the drawing to vector or hybrid in layout – setting it to raster shows is correct but not the ideal output for quality drawings.

I know there were some updates made since 2019.0. The first step would be to update to the current version. Make sure you install the update by right clicking on the installer and selecting Run as administrator from the Context menu.

I’m not sure if this is related to another issue with some edges being displayed when they shouldn’t be. After updating, you could try rendering in Raster and do a high quality PDF export to see how it looks. Raster rendering tends to look awful in LO because the rendering quality is set to medium or low to improve working speed. Export quality can be set higher, though.

Thanks Dave, just updated to 2019.3 – unfortunately it did not fix the issue.

I’ll do the raster workaround for now – I know I can change the output to be higher quality but I prefer to work in hybrid because it is a nicer product overall.

This seems like a fairly big issue, what’s the process to getting it looked into? can someone on the SketchUp team receive the file securely so I don’t post it on a forum?

I know that the LayOut team is working on fixes for some of these display oddities.

It might be that @trent or one of his folks would take your file as an example.