Clothworks lag

Hello! I am having an issue where clothworks for me seems to be laggier than videos I see online. My simulations drop below 1 FPS, despite having a very high end PC.

I have tried:
-Removing/hiding the Components and outline tabs (as suggested on the clothworks page)
-Removed profiles
-compared PC specs ton ones seen in videos

I am at a complete loss.

This isn’t a SketchUp bug.

How small are the subdivisions in your cloth component? What other properties have you chosen? What style are you using? Do you have Shadows enabled? There are a lot of factors that go into this.

Currently, for a quadrilateral grid, I put 3000, but regardless of the grid it is laggy. I put less & more and it doesn’t really make a difference. Same for the properties, I have yet to have had a smooth simulation with any property.

For the style I usually use the base one, no shadows, no profiles, no back edges, I go as minimal as possible.

Try a smaller number than 3000.

Still laggy, even worse at 0 FPS now. i dropped it at 1000. But what I don’t understand is I’ll see people online with lower end PCs run the exact same simulation, down to the grid number, and have it completely smooth. And I’m working on a new file, no bigger than 400 KB.

This is what I’m getting in SU 2022. There’s nothing wrong with the current version of Clothworks or SketchUp 2022. It must be something in your set up. Some videos out there showing it have been compressed to make it look like it’s running faster.


Maybe thats it. How many frames were you getting on this? And how many subdivisions did you use?

I don’t know what the frame rate was. I used Adaptive Grid with Padding set to 1.5".

I don’t use Clothworks, but a grid with 3000 x 3000 quad parts would result in 18 million faces.

1 Like

On the clothworks page, for the pillow tutorial, the creator puts 3000 for his grid, then proceeds to get a comfortable 5 FPS. On my end I get 0. It makes it a lot more difficult to manipulate the cloth afterwards.

I’m not sure to what the resolution refers, I got a grid of 55*55 when set to 3000 on one attempt
Anyways, I just tried it here and I get 5ish fps depending on how much I’ve playing around.4

The PDF tutorial mentions unsoftening the edges to see the grid structure - you need to soften it again or SketchUp may not perform quite so well

The pillow was just an example for the expected performance (at least, that i’d like), On a fresh, new file, with nothing but the cloth and collider, I hit on average 1 FPS, and that’s at it’s most optimal. I keep trying to see if I have the wrong settings or if something else is eating my juice but I cannot find anything :frowning:

What does the simulation use the most to run? The GPU, the CPU, etc. Trying to see if it may be on of my components, but I’m running an RTX 3090, i9 core and 64 GB RAM. I thought it would be enough.

All operations in SketchUp that create or modify geometry run mostly on the single CPU thread that it uses (like all 3D modelling applications).

Yeah, that should be fine - something must be up with that spec. The i9 will be doing most of the SketchUp stuff well and Clothworks can do some of its calculations multi threaded.
My machine is not as well specced as that and I’m getting 5fps on those.
Have you got the physics settings on the default?
I think I have mine on the 420 timestep - more precision will slow it down

Yes everything is on default on my end, haven’t modified the startup settings on clothwork just yet.

What are you using for Simulation settings? Do you have textures set to display? Shadows on?

In my previous example the Rate was set to 4 and Multi-threaded was Off. Here I’ve made some changes. Increasing the value for Rate reduces the number of renders. That should help your performance.

Changing the Timestep to something closer to 1/120 would help, too.

It helps a little bit, but not enough to where it’s efficient. There has to be something setup wrong for my CPU, because despite all my attempts it remains too laggy.

Are you sure you have Nvidia cart e as default on your system? I encountered a situation where the sellers were delivering badly configured equipment.

Yes, went into the Nvidia panel and made sure everything was where it should be.