Clipping & Terrain

I’m beginning to model my new home, little by little. After I modeled the basic structure, I added Geo-location terrain and imagery and then kept modeling. Problem is that now that I have the terrain added, I am experiencing clipping when I zoom in to model any type of detail, such as crown moulding.

122 Wright Road 1.skp (3.6 MB)

I know that I should be able to model intricate smaller details without issues, because I’ve done it countless times before. The only thing different about this model vs most others I work on is the addition of terrain and imagery. Is this the root of the issue?

If so, what is the solution so that I can design small details (mouldings, trim, hardware, etc) within my larger model without clipping?

Have you tried putting the terrain and/or imaging background on a layer and turning it off?

Or even make it into a component and delete it while you are modelling house details? You can always re-add it later from the Component Browser (so long as you haven’t purged it!).

Or even use Save As… to make sure you don’t do that by accident and lose it.

Do you need such a large terrain area for a house? Here is the clipping when zoomed in, then I ‘trimmed’ a bit of terrain off’…then here is the same zoomed in view and no clipping. As @john_mcclenahan said, you can also save the whole terrain as a component and ‘re-load’ it back in at the end if you need to see all of it.

Absolutely not. I simply went with the default settings.
It seems that having that much terrain is the culprit, as suspected. I’m still on SketchUp Pro 2018; I wonder if this would happen in the newest version. I don’t even know if this would be considered an issue :slight_smile:.

Just looking at the model itself.

If I turn off the terrain layer you already have, I don’t get any clipping when zoomed in close to a stair corner.

… although I CAN get it going in even closer.


Also tried opening it in SU 2020. Behaviour is no different.

I have the same experience here. Interestingly, before I added any terrain, I could get much closer in, which is what I’m used to. I sure hope there’s a way that in future versions, detailed (small modeling) can be completed without clipping on models with any terrain.

I’ve reimported terrain at a much, much smaller scale and it’s still clipping more than I’d expect. Quite frustrating, but I’ll do my best. Thanks.

Here’s a model I built earlier this year — TMT booth T.skp (4.4 MB) — which shows the kind of detail I am used to modeling. I can zoom in incredibly close on the moulding details here without any clipping whatsoever. That’s what I would like to maintain within my home model.

Does it make any difference if you copy and paste just the house part of your model into a new file, with no terrain?

You don’t need the terrain while you are detailing the house interior, do you?

When I do that in SU 2020, I can zoom REALLY close to a stair corner before clipping starts.

Or even this.

1 Like

Yes, if I remove all terrain, clipping goes away completely. I don’t need the terrain, but I do want to have it at some point when I start to do shadow studies on the deck/pergola remodel we’re about to undertake. It’s also nice to have a model with accurate terrain, especially when it’s your own home.

Then I’d suggest leaving the terrain out completely until you are happy with the house interior. Then add it back at the end.

1 Like