Objects in foreground getting clipped off

I have a large file, both physically and file size.
Interior scenes are getting clipped off.
I have toggled Hide Rest of Model but it still clips my model.

Here is an example. The shelves on the left are cut through, as is the wall to the right:

A common reason for such foreground-clipping behavior is when zooming in very closely relative to the total dimensions of the objects in the model. How far away from the world origin is the furthest item in the model?

I have a large a very large geo located site, about 50 acres, but that layer is turned off.
Does that matter?

In older versions of SketchUp I think the answer is yes. I’m not sure about the past three years or so. As an experiment you could temporarily delete the objects on that layer (in a copy of the master file, or just be prepared to quit without saving, or use Undo to restore the objects) and see if the clipping behavior changes.

What Dahl said, large areas can cause clipping when looking closely at things.

We made a change that should help. If you have Hide Rest of Model selected in the View/Component Edit menu, when you go into a components the rest of the model is hidden, and the clipping problem should go away.

Hi Colin.
That doesn’t help unfortunately.
Here I have turned off the site layer and selected Hide Rest of Model.

The result is the same. When I zoom in on a corner, the image is clipped. Everything in the perimeter of my viewports get clipped off, and when I zoom in on small features it’s worse.

Recently, as the model has gotten more complicated, the problem has gotten worse. I have purged unused, and clicked on fix errors to no avail. The file is about 30meg. Is that too large for Sketchup to handle?

Thanks for your efforts.

The size (in MB) of the SKP file is not a factor in visual clipping.

Did you try the experiment that I suggested - to delete the object(s) that are relatively far from the world origin and see if that affects the clipping behavior? That wouldn’t “solve” the problem, but it might confirm that the issue is due to the dimensions of the modeled space.

1 Like

Okay, I re-read your comment.
That actually works when I am editing individual components.

It’s nice to be able to edit components this way, but the point of the model, and of the program, is to illustrate the design.

When I show the model to my clients, it still clips everything in the foreground and perimeter of interior views. This is the main problem I’m trying to address.

I did a further test, trying what Dahl suggested. I deleted the location topography and map.
That works great, I can now see to edit. But is not a workable solution, because the house is sited in the mountains, and the clients and I need to see the views from the house, inside and out. Thus the large site.

Deleting the map is not really an option for any site with a view.

Two views, one with the site deleted.

See my previous reply to Colin.