Model size - How big is to big? Clipping


#1

I’m working on a large scale landscape where I’m placing a few cameras for getting pictures. The problem is that I get a lot of clipping in the model. My model is roughly 1500x2500 meters. Is that to big for working with? Is there anything else I can do about it? I really can’t scale down the model. See attached images of full landscape as well as a camera with lots of clipping.


#2

Here’s a pic of the clipping:


#3

Try the “Zoom Extents” (there is a tool button and the Quick-Key combination is [Ctrl + Shift + E]) this feature shows the entire model from your present angle, then move in as you want.


#4

Unfortunately not solving my problem. As I zoom in again the model starts clipping. I’ve also tried deleting geometry that’s very far away (there was none), and changing the field of view. None of those things helps.


#5

Have you checked the YouTube “Fixing Clipping in SketchUp”?


Maybe there is something there among the four issues that are covered?


#6

Yep, those are the steps I’ve followed. In the video they say that too big of a model may be the problem. My slice of landscape i kinda big but scaling it down isn’t an option so that’s why I’m thinking the size might be a problem. Hence the heading. But I really don’t think it’s unrealistically big, so I’m hoping for another solution :slight_smile:


#7

I’d be happy to supply the model if anyone would like to take a look.


#8

That’s always the best way to help us help you.
3MB limit for attached files here in the forum or share it on the cloud at, say, Google Drive?
Or the 3D Warehouse.


#9

I’ve put it in my Dropbox folder for public access. Download the .skp file here:

https://dl.dropboxusercontent.com/u/749939/Issues%20with%20clipping.skp

I’d greatly appreciate any help with this!


#10

If you open outliner you will find these two groups I have highlighted in the image. Somehow you have created them with the origin a long way from the model. If you explode them your clipping goes away. You may even be able to simply delete them, I didn’t check to see what they are.
As you can see, the bounding boxes are huge and the speck in the middle is your model.


#11

Regarding to the highlighted boxes that @Box mentioned, I think that from the layer Camera_FOV_Lines, when I turned on hidden geometry, there really long lines in there and made your overall model really large. So my guess is that with those lines, your model is too large.


#12

Looking around a bit more I think you have multiple issues that are causing the problems.
I wouldn’t be surprised if some of your problems are coming from imported .dwg, you seem to have quite a bit of it in there hidden.
Also your layers are problematic. You have raw geometry on layers other than Layer0. You shouldn’t do that, only put groups or components on other layers.
In other words if you look at the entity info of an edge or a face inside a group, it should say layer0 even if the group itself is on another layer.
The only way I found to remove the clipping totally was to copy the model by using a selection fence, not Crtl+a and paste it into a new empty model.


#13

A HUGE thanks! I’ll will give this a shot and leave a comment with the result.


#14

The stuff created by ACT is >220 kilometers across.
Is that necessary? Would ordinary Scenes and Camera settings do what you want?



#15

Indeed the volumes and lines of the ACT was the problem. How come they are created so huge?

plus thanks for the tip on working with layers and groups. I was not aware of that.