Cleanup without face weld

ifc´s often have triangulated faced, that will make the model more complex and with huge file size and random snap points, so its a a perfect candidate for the cleanup extension. ( cleanup3 ) from Thomas Thomassen.

the ifc file ( as with steel parts from Trimble Tekla engineering modeller) have round edges shown as separate surfaces typical of sketchup rounded edges, with hidden lines in the curvature, like this:

This makes for a good enough looking model with good performance. But after cleanup, with only using “merge coplanar faces”, I get this:

All the random triangulation is gone , but the face is now softened, and looks nicer, but if you have hundreds of these steel parts you get a real performance hit.

And these faces that are not coplanar should not be affected by the plugin settings?

What am I missing here?
part.skp (362.2 KB)

Check your axes, the bounding box is huge and will cause clipping, so move it back to the component.
Shown first in the gif.

Then are you talking about the strange hidden geometry? Sometimes one extension doesn’t fix everything. Here I have used Fixit 101 to get rid of those edges and faces.
Fixit edges

oh thanks a lot. Off I go to the extension warehouse.

I’m not sure but I don’t think it’s in the warehouse.

It is definitely in the Sketchucation Store. Fixit 101

downloaded it, and it works fine except for me it has the exact same behavior. I guess for you too, if you hide hidden geometry, and try to select the face after that, it will select the compound face, that is welded or softened or something. :slight_smile:

It sounds like you just don’t quite understand the geometry in sketchup.
The edges in a curve face need to be there whether they are hidden, softened or hard.

1 Like

When I opened your file the end is a whole bunch of faces subdivided by hidden edges that are superfluous. CleanUp and Fixit1010 get rid of those unneeded edges.

That triangulation is not useful in this case. Try using Push/Pull on the end of the beam. With all of that triangulation, Push/Pull won’t work. After clean up, it will.

hi. I understand they have to be there, expect they were hidden lines to begin with, before the cleanup, and and with just hidden lines separating the faces that make up the curve you can still select individual faces. After cleaning there is no individual faces unless you show hidden lines, just like you can get into individual faces in a softened object, if you show hidden geometry.

yes. This is an imported file from another party, and cleanup is the mission. But I would rather keep my segmented curved surfaced.

The curved surface is still segmented. If you want to see the facets you can select those edges and turn off Smooth in Entity Info.

yes it is still segmented. but before cleanup I had hidden lines, and after cleanup I have smoothed surfaced, and when I unsmooth, I have this:

, not hidden anymore. So either my model is heavy from smoothed surfaces, or cluttered from lots of lines that were hidden to begin with. That is my dilemma. I could hide them again manually, but with hundreds of objects in my steel import I would not be finished before the engineer sends the next revision :-).

There is no difference in the weight of the model whether they are hidden, smoothed or hard.
The only way to remove them is to remove the curve.

1 Like

I wrote:

It’s only an appearance thing, though. It has no effect on the file size.

I know there is no difference in terms of the weight of the model, but performance when zooming and orbiting feels strained with lots of smoothed objects.

Actually, performance should be better with things smoothed as there are fewer edges for it to render.

1 Like

you are right. my beachball issues was from something else. Maybe from not purging the old steel import after inserting the revision… that seemed to do the trick.

This is basic SketchUp.

In SketchUp, edges can be

  • soft = treated as if the adjacent faces are parts of a single surface
  • smooth = cause shading of adjacent faces to blend across the edge as if there is a smooth joint rather than a dihedral
  • hidden = not visible regardless of soft or smooth

An edge with any of these set is not displayed unless View->Hidden Geometry is on.

When View->Hidden Geometry is off, adjacent faces whose shared edges are soft are treated as a single surface. You can select only the whole surface, not the individual faces or edges. On the other hand, when View->Hidden Geometry is on, you can select the individual edges and faces making up the surface.

1 Like

Have you tried the latest IFC manager plugin:

Besides exporting proper(ties)ly, it also has an import IFC button which takes care of the triangulation.

cool. will try that. IFC manager is an invaluable plugin from a dedicated developer.

1 Like