Why some coplanar faces are merged and others are not when using the cleanup extension?

So, why some faces were merged and others were not? I was actually trying (and so far not good) to do a tutorial in to how to make a couch and I came accross this observation.

Can you share the .skp file?

box.skp (140.7 KB)

Interesting. CleanUp deleted all of the coplanar edges for me. I was wondering if you had some internal faces but there aren’t any in the model you shared.

I opened the same file I sent you and tried a few times to clean it up. I would like to make a video too, but I don’t know how to do that lol When I tried it recorded only one window

Maybe it’s just a bug.

If it’s a bug we’d both have it. Same extension and same version of SketchUp.

I recorded the GIF with LiceCap which is freely available.

Maybe some part of the code is in conflict with other parts of other numerous codes in my operational system, then it’s a bug related to something in my computer as a whole.

That might be but I wouldn’t expect it.

What happens if you just erase the edges?

It can be erased as usual. But I don’t want the faces to be merged, I actually want all those lines, this was just something curious I ended up finding. But I don’t know… Maybe in the future I will have problems if I actually wanted to merge faces…

Ah… Definitely a weirdness.


Now I’m a bit upset that I have this drawback. But thanks for the help anyway.

Don’t let it bother you. There are other ways to deal with that sort of stuff when needed and you shouldn’t run into that many cases of coplanar edges to delete in most of your modeling.