Clarification on field of view

Continuing the discussion from Confused about Field of View Camera Settings:

I have noticed that I can type “35mm” or “35 deg” in field of view VCB.
I also have noticed that SketchUp seems to remember what unit that I have used for the last time.
Therefore, it shows 57mm as default field of view, but if i use “deg” unit and restart sketchup, it would display “35.00 deg.”

I believe these two are default value of SketchUp 2015 Pro.
In Clipping & missing faces - http://help.sketchup.com/en/article/36261
states that “One is when the field of view (FOV) is set very wide. You can adjust the FOV between 1 and 120 degrees (the default is 35 degrees in SketchUp and 30 degrees in SketchUp Pro).”

  • In unit of “deg.”, why 35 deg. in Make versions and 30 deg. in Pro versions?
  • I do not remember what SketchUp displays in unit when it ships. Is it in “mm” or “deg”?
  • If it is in “mm” why not use something that people are more used to (50mm as standard) than 57mm? and change the way its calculated to do “expected” behavior.
  • Why not calculate the Angle of View on diagonal like photography, as suppose to vertical?

According to Wikipedia (which is not infallible, of course):

Yes, it can be measured vertical OR horizontal OR diagonal.
but it is limited only to Vertical

and according to more infallible source CANON website:

The nominal diagonal angle of view is defined as the angle formed by imaginary lines connecting the lens second principal point with both ends of the image diagonal.

To muddy the waters a little bit;
When you import a photo and “photomatch” it (setting the vanishing points), then the angle of view normally changes (about 70-75º normally). However this does not take into account any curvature of the lense; isn’t it a bit pointless trying to be accurate with the angle of view when there is no barrel distortion?

SU uses OpenGL which uses the vertical field of view…

‘Advanced Camera Tool’ shows a real camera ‘Image Plane’ for those needing them…

most people don’t know the Field of View or Focal Length of their phones, so the numbers are irrelevant for them…

john

2 Likes

SketchUp is not a camera. It uses a monitor to display results in a wide variety of sizes and aspect ratios. Rather than try and provide a long list of settings to accommodate the range of possible display devices, it makes more sense to use the vertical reference since almost all computer monitors in normal use have a wider field of view horizontally than vertically. Which angle of view would make more sense if I want to view a sphere from any imaginable angle?

[edited] BTW, 35mm film uses a 3:2 aspect ratio. All 35mm camera lenses reference this, so the diagonal is just as good as either vertical or horizontal. However, this underlying use assumes the 3:2 aspect which, while close to the Golden Mean, is rarely encountered in the video monitor world.

2 Likes

I see. Thanks for the explanation.

True that. That makes sense.

Do any of you know why we jump from 35 deg to 30 deg between pro and make versions?
does this also has to do with advanced camera tool?

I have a vague recollection that it was more to do with the 3d Printing Template being aimed at the ‘Make’ market…

And the 3d template is nothing more than 2mb of wasted space.

1 Like

Lol, I guess that makes sense and doesn’t at the same time.

and…
Anyone know if we are meant to type in as deg or mm? idk which makes more sense at this point.

I made a Plugin to try and figure it all out once, but they are oddly linked…

use whichever you can cope with…

3 Likes

Very nice!

Thanks for sharing!

Hi Folks, I am having a problem with clipping on my scenes. I have looked at my model and it is on the axis and there is no geometry out in space (far away). A few scenes are clipped. If I go from a scene to model extents zoom the clipping disappears. If I go back to the scene it reappears. I can set my field of view from 35 deg to 25 deg, but it seems to be remembered at 35 on my scenes. I reset field of view to 25, go to a scene. Field of view is greyed out. I click Camera, Perspective then Field of View and it is back to 35 deg. I have a bunch of scenes and am trying to layout my final copies but cannot get rid of the scene clipping. Is there any way to globally reset my Field of View so it affects my scenes or do I have to redo everything?
Thanks

If your scene manager is set to retain the camera (i.e., “Properties to be saved Camera location” is checked), it will store the settings with the scene. However, if you make any changes to a scene at all, make sure to right-click the scene tab and update the changes. Otherwise, they will revert to the scene creation settings or last update made.

Make sure you are in “Perspective” mode for the camera when you save or update your scene. The field of view only has relevance with perspective views.

The easiest way I know how to do so is to open the Scene Manager and highlight all of the scenes. Then uncheck the “Camera location” box and make the FOV settings in the first scene. Click update and then go back to the scene manager. Highlight the scenes and check the “Camera location” box … that should reset all subsequent scenes to the currently displayed settings.

1 Like

HI Jimhami42, thanks for responding. On my scenes I want to have the camera on Parallel projection to get front, side and top elevations in Layout. If I go to Perspective or 2 Point Perspective I get the 3d view and not the standard drafting layouts. I cannot then make the FOV changes in any scene (since it is not available). Perhaps I am missing something here.

I may well be the one not understanding your question. I’ve uploaded a model with six scenes. Scene 1 is the plan view, scene 2 is the front view, scene 3 is the right view, scene 4 is the rear (back) view, and scene 5 is an isometric view. The clipping is determine solely by zooming in or out to the size you want and then updating the scene. Scene 6 is a perspective view where I have set the FOV to 25 deg and updated the scene (you didn’t specify which version of SketchUp you are using so I uploaded it in 8).

scenes.skp (31.5 KB)

If you want all the views laid out at once like you might see on a blueprint, then create multiple copies of the geometry and place them in one view:

BTW, are your questions relating to using “Layout” in the Pro version? Or just the scenes in general?

HI jimhami42, I have a number of scenes displayed like your example and clipping is occurring in a couple of scenes. I am using Sketchup pro 2015. In trying to use your example:
Go to scene manager highlight all scenes, uncheck camera location box, highlight one scene with an iso scene where the camera is set to perspective, and change FOV. I update only that scene with the camera location box not checked. I highlight all scenes and check the camera location box. Now all my scenes are from the same iso camera location (rather than front side top etc.)

The trick with the “Camera position” was in response to your question about setting all the FOVs at once. This also reset the camera position (or viewpoints) for all the frames.

Open your first scene and set everything the way you want it (including perspective, clipping, shading, layers, FOV, etc.) and then right-click that scene tab and click “Update”. When you come back to it, it should be the same. Now click on your second scene tab and repeat these steps. Loop through each tab until done.

To simplify matters let’s say on the model you sent that I want to change the FOV on all the scenes you created. They are presently at 25 degrees. In this case I want to make them all 35 deg. The scenes 1 through 4 have the camera at parallel projection and have the FOV embedded at 25 deg. I want to retain the camera position with the new FOV.