Changing color of texture on model

I am attaching the free model by AXYZ that shows a variety of different colored jackets. I extracted the image using paint bucket and then adjusted the jacket color in Photoshop. When I reimported the image using Paint bucket, it gets all turned around. I even reimported the extracted texture
and again it gets all turned around. Any step I’m missing? Why doesn’t the texture just go back in the same place? I’m attaching a pdf of the steps I used.
jacket.pdf (420.3 KB)

Share the .skp file so we can see what you are working with. It might be as simple as the color profile that Photoshop uses to save the edited texture. I’ve had problems with PS like that. I prefer a different editor called PaintDotNet. It doesn’t screw with the color profile and it saves back to the temp folder where the texture is placed by Sketchup while editing.

Example. Original component.

Texture image edited in PaintDotNet. I didn’t spend any time on this so it’s a little sloppy.

Immediately after hitting Save and returning to SketchUp.

The SketchUp file is large. Here is a link:

Well, this is what I get with PaintDot Net. I didn’t spend much time editing but I changed the color of the green shirt.


Quick edit:


Out of curiosity, how are you using the components?

I reduced the texture image sizes to 1024 px and merged coplanar faces in the model. That reduced the fule size by about 72%. I expect further simplification could be done without hurting the appearance significantly. That would be especially useful if you’re sticking these guys in a larger project file.

I was planning on using the models in my Photoshop class as an example of how to slightly edit models by just color changing. Professionally, I have slightly edited models by adding school logos to the extracted image and then reimporting them. It works well usually but in this case I cannot get the image to come back in place.

I resized the texture to 1024x1024 as you suggested and this is what I get:

I export out to Irfanview. Save the file. Then open the file in Photoshop to edit. When I export, the file is 4096x4096, 96dpi, 24 bit by default. When you export, what file size, dpi, bit depth are you getting?

I’m not sure if file settings really affect the model. I just checked a model and graphic files that work as I expect and the image is 2835x2835, 72dpi

Are you doing anything special or using a plug in when exporting or reimporting the adjusted image back into SketchUp? Are you needing to reposition the texture at all?

Here is the texture I get when I export:

Here is an example of the original model and one with a school logo on a shirt. I changed the color of the shirt and took off the tattoo too:

I have PaintDotNet set as the default material editor in SketchUp’s Preferences>Applications. Then in the Materials panel I right click on the material thumbnail and choose Edit Material. The image opens in the image editor where the color and other adjustments can be made.

I used an extension from the Extension Warehouse called Material Resizer to resize the materials. In the case of your model I resized all of the materials in one swell foop.

I think a lot of your problems stem from the way you are exporting the image and manipulating it.

1 Like

Your way of working by exporting the image, editing it and then reimporting it creates a scale difference between the image and the UV unwrapped model.

You can fix this, but it is much simpler and accurate to set up a photo editor in SketchUp - Window > Preferences > Applications > Default Image Editor, and just edit and save.