Change unit precision only for one dimension in SketchUp model?

dimensions
precision

#1

Is there a way to change precision for a single dimension in model (like in LayOut)?
Or maybe it is possible with a ruby script?

Reason - sometimes you want to show some dimensions precise without clattering all model with unnecessary zeros after commas for other dimensions.

I know, you can add text to dim by writing <> before text or add \n to make text in new line. Maybe there is some code to change precision also?


#2

Dimension precision is set by model not by the individual dimension in SketchUp. You could manually edit the dimension to type 207,5. Normally all dimensions in the drawing should have the same degree of precision to avoid confusion.


#3

Also, if you manually enter text the dimension will not be associative. That is, if you change the edge marked by the dimension the text will not adjust to match. Dimension objects don’t have individual precision settings, so there is no way a Ruby extension could do any different.


#4

OK, I see. Thank you!
I still think it would be great to have a feature where SketchUp shows units after comma only if they are greater than zero.


#5

Add dimensions in LayOut and you can do that.