Can't set unit precision in Document Setup

I seem to be stuck with 1" precision in dimensioning tools. Have tried changing to 1/8" in the Document Setup, but no joy. What am I missing?

‘Model Info’ >> ‘Units’

I am talking LayOut (on a Mac). My SketchUp model is in 1/16" precision, but I can’t seem to change the LayOut drawing precision in the Document Setup units pane.
All my dimensions are showing up in 1" increments.

LayOut is kinda weird. The info in the Dim Style inspector is meaningless when nothing is selected.

I (and most people,) would expect it to be the global style when nothing was selected, or the page style when a page was selected, etc. But apparently not.

Anyway, try this… pick the SelectTool, and click nothing.
Then Edit (menu) > Select All
If there are dimension objects on the page they should be selected, and the inspector will show non-greyed controls that can be adjusted for all selected dimensions.
Change the dimension precision setting.
Do all the selected dimensions update ?

If not. Are the dimensions on a locked layer ?
If so. Unlock the layer, and try again.

Hey, great! Thanks very much for the help!

Model info has format window put it to meter!

There is no ModelInfo window in LayOut. There is a Document Setup window, but when dimensioning, you can choose to display other units than specified there.