Can't use pushpull on this model to create holes

Frustrated again. So I have this Fibonacci pattern which is to be a pattern on a flat 15mm thick board in my model. I grouped the pattern and dragged it to align with the 15mm board. I thought I could then double click on parts and push them to pierce the board and create openings. But it doesn’t work. I tried exploding everything and rgrouping but it didn’t work either. Love some help on this please!

Sounds like you are trying to do things while in the wrong context, but we can only guess.
Attach your model so we can tell you exactly what is going on.

Untitled.skp (81.5 KB)

sorry I should have attached it. THanks. So for example, I would like to be able to push that centre quadrant to make a hole. Or any other parts for that matter.

1 Like

The pattern is within it’s own group so it won’t interact with the board. Explode the inner group to make it merge with the board.


I tried exploding the group but now I get unpredictable selection of the sections. Before I initially grouped them, I confirmed that I could select each individual section, but now it’s exploded, it’s changed.
Untitled (1)~.skp (83.0 KB)

1 Like

Triple click, right click, Intersect Faces with Selection.

I suspect something is just out of alignment which is causing the zfighting of the faces. Go to Preferences/Model Info/Units and turn off length snapping. This can help with accuracy because it doesn’t limit the point placement to a specific length.


Thanks. Should I recreate the model from scratch with the snapping turned off? Should I turn angle snapping off too? CHeers

1 Like

Angle snapping isn’t important in that sense. If you go back to your original, you can always download it if you don’t have it, and delete the top face of the board, then explode the pattern you’ll get it all nice and neat.

By the way, do you know you are modelling upsidedown? The blue is the sky and the green is the ground.

1 Like

OK, will give it a go. Lol, yeah I know, I just copied this part out of the original file and when I pasted it in a new window it came out in a different orientation and to view it the way I was used to it I just rotated the view. Plus I like blue :slight_smile:

Here’s a quick remove face and explode. But as you see there is still something slightly out of alignment as one of the faces doesn’t cut through.

1 Like

Thanks. I think I will remake the whole thing from scratch. Shouldn’t take too long. Maybe I should make the ‘board’ first and draw the pattern directly on it rather than applying the surface to another board.

That would be the way to go.

You shouldn’t need to redo everything. You just need to flatten it and get ride of the bad overlapping faces so you’re starting with just your edges.

I used Eneroth Flatten to Plane and then Eneroth Face Creator to get nice clean faces to extrude again:

1 Like

You know there are easier ways to delete all faces!

1 Like

Yes. Brain not warmed up yet. Here’s one of many ways!

1 Like

True you got a flat design, but it’s still not sitting on a 15mm board. Simply starting with the thickness and drawing the design works better in this case.

Everyone happy now?

I try to teach without plugins when at an early stage. It’s best to know what is happening before automating it with an extension.

1 Like

Thanks, I only saw the conversation this morning. Yesterday I rebuilt the back board and pattern and was able to use it predictably. This is the first pass of the design with details. Thanks for your help.


Nice application for designing the shelving.