Can't update or install from Sketchucation


I get this error every time I try to update an extension or when I try to install a new extension.
Never had this problem before, started a few days ago.
Anyone knows what the problem might be?

Did you post about this on the Sketchucation Forum?

No, not yet. I’m not familiar with that forum. Will do!

After posting, the first thing you should do is download and install the current version of the Sketchucation Extension Store tool. The version you show (3.0) is old. The current version is 4.1.0

https://sketchucation.com/resources/plugin-store-download

Download it and use Extension Manager to install it. Restart SketchUp and try installing LibFredo6 again.


Same problem after updating Extensionstore to 4.1.0

Did you restart SketchUp after updating?

Clear browser caches too.

did restart, which browser is used by the Sketchucation extension store?
Edit: I just cleared the cache for Firefox. Still the same error…

I suggest you post a message on the SketchUcation store support page of their forum:

https://sketchucation.com/forums/viewtopic.php?f=15&t=63458&sid=4cfb5abc04ea69b41d22b686f7f41254&start=300

They are typically pretty good at diagnosing and fixing issues.

The store is a website, it doesn’t use any particular browser. But there could be compatibility issues with some browsers, especially since the store recently migrated to a new server.

See if this topic from 2015 is somehow helpful. Test the last two posts (proxy or antivirus).

https://sketchucation.com/forums/viewtopic.php?f=15&t=60538

I just posted there.

I disabled antivirus, no dice…
I don’t know were to look for that proxy-setting.
I didn’t change anything on my computer since I last updated succesfully. (that I know of)

Try clearing the web-browser cache for Internet-Explorer - that is used for some legacy dialogs in ExtensionStore³.
The PluginStore was recently migrated to a new server, and your cached data might be looking at the old site and getting confused when trying to auto-install extensions…

Can you download the RBZ from the PluginStore directly, then install it manually ??

Incidentally, Fredo did have some issues with recently updated RBZs, but as far as I know this is all fixed - several days ago…

I can’t find internet explorer on my computer. Cleared the cache of microsoft edge instead. doesn’t help.
I downoaded the newest version of extension store3 tool from the website and installed via Sketchup extension manager - install extension. that worked! But the tool still doesn’t work. Have also tried to install new extensions not made by Fredo. always the same error…

I think that the Edge cache is now shared with Internet Options…
You can access that from your ‘settings’…
Browsing History > Delete ??

Tried that, didn’t work either.

I downloaded the latest version of LibFredo and installed it via SketchUp extension manager. restarted SketchUp, and now Sketchucation extension store3 tool says everything is up to date…
Same for another extension i wanted to install from Sketchucation.
Just annoying that the extension tool doesn’t work…

An idea… off at a tangent…
The ExtensionStore³ auto-install might need to write temp files etc.
If you have not installed SketchUp properly it might prevent a smooth process…

Here’s how SketchUp should be installed/repaired…

Log in to Windows as your normal user-account.
Ensure that SketchUp etc is NOT open.
Find the SketchUp installer-file exe’s icon - usually in your Downloads folder…
Select its icon, right-click > context-menu > “Run as administrator”
When prompted choose ‘Repair’ [nothing you have already customized will be affected…]
Afterwards retry things - it will do no harm…

Alternatively try to delete the temp folder used by ExtensionStore³…
SCF::TEMPDIR [used in the Ruby Console]
giving…
C:/Users/YOURNAME/AppData/Local/Temp/SCF

Restart SketchUp after doing any of this and see if it helps…

I did install SketchUp by running the installer as admin.
Will try a repair when I’m home again in a few days.