Can't sign into SketchUp subscription

I have a SketchUp Pro subscription, which I have recently renewed. Now I can’t sign in to my subscription to open SketchUp. When I launch the program I get the sign in screen. When I click the “sign in” button I get the “relaunch browser” button, which does nothing. SketchUp customer service has been completely unresponsive for several days.

In desperation I uninstalled SketchUp Pro 2022, signed in to my account on the SketchUp website (no problems there) then downloaded the application from there. However the downloaded .dmg file will not open. I just get a dialog box saying “can’t open the file; resource busy.” I tried downloading again with the same result. Now all I have is an unopenable disk image file. This is driving me crazy. Can anyone help?

Uninstalling SketchUp probably just complicated things unnecessarily. First step will be to get a working version reinstalled. Have you tried restarting the computer and then opening the .dmg from the finder.

Thanks, Riley: Restarting the computer allowed me to open the .dmg file and reinstall SketchUp. However the problem is not cured. When I launch the program, I get the sign-in dialog box. I click the “sign in” button, and it changes to “Complete the sign in process in your browser,” and offers a “Launch Browser Again” button. Clicking this button still does absolutely nothing. If I launch the browser manually and sign in to my SketchUp account, that doesn’t work to open the program either.

Could the problem be that I have FireFox as my default browser? This has never been a problem before. But I’m willing to try anything at this point.

According to system requirements, SketchUp Pro 2022 requires MacOS 10.15 or newer. You say you are using 10.11.3. This might be the reason, or then browser settings like a popup blocker.

Try using safari or chrome. Can’t hurt?

There may be a Firefox security setting that prevents other applications from opening a web page. Trying with Safari or Chrome would be worth a go.

Actually I am running OS 11.6.8. This is the the latest system version My desktop will run. It’s a late 2014 27" retina 5K iMac. I have tried switching the default browser to both Safari and Chrome, restarting the computer each time, but still get the same result. “Launch Browser Again” button doesn’t work.

I have finally heard from SketchUp customer support, and they have solved the problem. All I had to do was delete the " login_session.dat" file from the Application Support library. Everything is fine now.

It would help if you would update and complete your forum profile since that information is important for us to be able to help you.

With the correct information in your profile we would have probabbly given you the same advice at least a day or so ago.