Can't seem to close some of these holes

Hello:) attached is an stl i need to clean. I need to make it a solid so that i can use this for an assignment.

I ran solid inspector and have been painstakingly closing all the holes. started with 18, now only have 12 left. But it has taken about 1.5 hours to do so because some holes just wont close at all and i do not know why.

The model is scalled 1000 times. There are 12 holes and 18 edges left. But just needing to know how to close these holes the best and fastest way haha.

this hole is on the finger/knuckle joint i think.

1000 scale remixed palm1.skp (2.7 MB)

The opening looks almost triangular, but isn’t. Carefully join vertex to vertex, and reverse faces where necessary.

There were four triangles needed to completely close the hole visually.

I found I needed to draw over two or all three sides of some triangles to get them to close.


Speaking for myself, I find it hard to tell which faces are selected, and which reversed, with your choice of front and back face colours, but each to his or her own.

Certainly, modelling at 1000x scale helps - it would be impossibly difficult otherwise.

Patience needed, though, to fix the remaining holes.

PS. And when I use Solid Inspector 2 I find two problems with this fix.

  1. I made it in the wrong context, which I could fix by cut to clipboard, open the group for editing, and paste in place.

  2. There’s still a Surface Border issue on what is apparently one edge, but isn’t.

Why do you have two nearly identical groups, and which one are you trying to fix?

I’m sorry, but I don’t know of any simple way to fix the holes, other than painstakingly drawing edges to join all relevant vertices.

Do you have access to any other format of the model? STLs are always triangulated, and can be hard to fix, as these are.

Another thing to fix is that your Model Info > Units is checked to use length-snapping of 1mm.
Uncheck that as it can result in weirdness as drawn lines are not exactly as expected…

2 Likes

Nope, just access to stl’s:)

One is the original file which has the rectangular vents on the bottom, but i dont like how it prints and has so many retractions, so i remodeled it to have circular vents. That is why there are two of them. I forgot abour that haha.the one im trying to fix is the model with circular vents

The color scheme is setup that way so i can model at night and not hurt my eyes. Wish su pro had a dark ui theme haha.

Thanks

Dang it! Thats what i keep forgwtting to turn off. Where is that located? Is it under model info units?

Thanks

Yes.

Open any or all of your most used templates, turn it off there, then Save As Template, so your new drawings will all have it off too.

1 Like